Astra® LoadTest™
Analysis User’s Guide
Version 5.4
# Table of Contents

Welcome to Astra LoadTest ...............................................................vii  
Online Resources .............................................................................vii  
Astra LoadTest Documentation Set ................................................viii  
Using the Astra LoadTest Documentation Set ................................ix  
Typographical Conventions............................................................x  

### Chapter 1: Introducing Astra LoadTest Analysis 1  
About the Analysis .................................................................2  
Creating Analysis Sessions .........................................................3  
Starting the Analysis .................................................................3  
Collating Execution Results ........................................................4  
Viewing Summary Data ..............................................................4  
Aggregating Analysis Data ..........................................................5  
Setting the Analysis Time Filter ..................................................7  
Setting General Options ............................................................9  
Setting Database Options ..........................................................10  
Working with Templates ............................................................12  
Viewing Session Information .....................................................14  
Analysis Graphs .................................................................15  
Opening Analysis Graphs ...........................................................17  

### Chapter 2: Working with Analysis Graphs 19  
About Working with Analysis Graphs ..........................................20  
Determining a Point’s Coordinates ...........................................20  
Performing a Drill Down on a Graph .........................................21  
Enlarging a Section of a Graph ....................................................24  
Changing the Granularity of the X-Axis ......................................24  
Applying a Filter to a Graph .......................................................27  
Grouping and Sorting Results ....................................................31  
Configuring Display Options ....................................................32  
Viewing the Legend .................................................................36  
Viewing the Data as a Spreadsheet and as Raw Data ..................38  
Viewing Measurement Trends ..................................................40
Chapter 3: Vuser Graphs

About Vuser Graphs
Running Vusers Graph
Vuser Summary Graph
Rendezvous Graph

Chapter 4: Transaction Graphs

About Transaction Graphs
Average Transaction Response Time Graph
Transactions per Second Graph
Total Transactions per Second
Transaction Summary Graph
Transaction Performance Summary Graph
Transaction Response Time (Under Load) Graph
Transaction Response Time (Percentile) Graph
Transaction Response Time (Distribution) Graph

Chapter 5: Web Resource Graphs

About Web Resource Graphs
Hits per Second Graph
Throughput Graph
HTTP Status Code Summary Graph
HTTP Responses per Second Graph
Pages Downloaded per Second Graph
Retries per Second Graph
Retries Summary Graph

Chapter 6: Web Page Breakdown Graphs

About Web Page Breakdown Graphs
Activating the Web Page Breakdown Graphs
Page Component Breakdown Graph
Page Component Breakdown (Over Time) Graph
Page Download Time Breakdown Graph
Page Download Time Breakdown (Over Time) Graph
Time to First Buffer Breakdown Graph
Time to First Buffer Breakdown (Over Time) Graph
Downloaded Component Size Graph

Chapter 7: User-Defined Data Point Graphs

About User-Defined Data Point Graphs
Data Points (Sum) Graph
Data Points (Average) Graph
# Table of Contents

**Chapter 8: System Resource Graphs** ................................................... 95  
About System Resource Graphs ............................................................... 95  
Windows Resources Graph ................................................................... 96  
UNIX Resources Graph ........................................................................ 100  
SNMP Resources Graph ....................................................................... 102  
TUXEDO Resources Graph .................................................................... 103  

**Chapter 9: Network Monitor Graphs** ................................................ 105  
About Network Monitoring .................................................................... 105  
Understanding Network Monitoring ...................................................... 106  
Network Delay Time Graph ................................................................... 107  
Network Sub-Path Time Graph ............................................................... 108  
Network Segment Delay Graph ............................................................ 109  
Verifying the Network as a Bottleneck .................................................. 110  

**Chapter 10: Firewall Server Monitor Graphs** .................................... 111  
About Firewall Server Monitor Graphs ................................................ 111  
Check Point FireWall-1 Server Graph ................................................... 112  

**Chapter 11: Web Server Resource Graphs** ....................................... 113  
About Web Server Resource Graphs .................................................... 113  
Apache Server Graph ........................................................................... 114  
Microsoft Information Internet Server (IIS) Graph ................................ 116  
iPlanet/Netscape Server Graph ............................................................. 118  

**Chapter 12: Web Application Server Resource Graphs** .................... 121  
About Web Application Server Resource Graphs ................................ 122  
Ariba Graph ......................................................................................... 123  
ATG Dynamo Graph ............................................................................. 125  
BroadVision Graph .............................................................................. 128  
Brokat Twister Graph .......................................................................... 135  
ColdFusion Graph ............................................................................... 139  
Fujitsu INTERSTAGE Graph ............................................................... 140  
Microsoft Active Server Pages (ASP) Graph ....................................... 141  
Oracle9iAS HTTP Server Graph .......................................................... 142  
SilverStream Graph ............................................................................ 146  
WebLogic (SNMP) Graph .................................................................... 147  
WebLogic (JMX) Graph ....................................................................... 149  
WebSphere Graph ............................................................................... 152  

**Chapter 13: Database Server Resource Graphs** ............................... 159  
About Database Server Resource Graphs ............................................ 159  
DB2 Graph ........................................................................................... 160  
Oracle Graph ...................................................................................... 174  
SQL Server Graph ............................................................................... 176
Chapter 14: Cross Result and Merged Graphs ........................................... 179
About Cross Result and Merged Graphs ............................................. 179
Cross Result Graphs ............................................................................... 180
Generating Cross Result Graphs ..................................................... 182
Merging Graphs ................................................................................. 183
Creating a Merged Graph ............................................................... 185

Chapter 15: Understanding Analysis Reports ........................................ 187
About Analysis Reports ...................................................................... 187
Viewing Summary Reports ............................................................. 188
Creating HTML Reports ................................................................. 189

Chapter 16: Managing Results Using TestDirector .............................. 191
About Managing Results Using TestDirector ................................... 191
Connecting to and Disconnecting from TestDirector ...................... 192
Creating a New Session Using TestDirector .................................... 195
Opening an Existing Session Using TestDirector ............................ 197
Saving Sessions to a TestDirector Project ....................................... 198

Chapter 17: Interpreting Analysis Graphs ............................................. 199
Analyzing Transaction Performance .............................................. 199
Using the Web Page Breakdown Graphs ......................................... 202
Identifying Server Problems ........................................................... 204
Identifying Network Problems ......................................................... 205
Comparing Scenario Results ........................................................... 206

Index .................................................................................................. 207
Welcome to Astra LoadTest

Welcome to Astra LoadTest, Mercury Interactive's tool for testing the performance of Web-based applications. Astra LoadTest stresses your entire Web-based application to isolate and identify bottlenecks and optimize the end user experience.

Astra LoadTest enables you to test your system under controlled and peak load conditions. To generate load, Astra LoadTest runs hundreds of Virtual Users that are distributed over a network. Using a minimum of hardware resources, these Virtual Users provide consistent, repeatable, and measurable load to exercise your Web-based application just as real users would. Astra LoadTest's in-depth reports and graphs provide the information that you need to evaluate the performance of your Web-based application.

Online Resources

Astra LoadTest includes the following online tools:

Read Me First provides last-minute news and information about Astra LoadTest.

Books Online displays the complete documentation set in PDF format. Online books can be read and printed using Adobe Acrobat Reader, which can be downloaded from the Adobe Website at http://www.adobe.com. Check Mercury Interactive’s Customer Support Web site for updates to Astra LoadTest online books.
Astra LoadTest Analysis User’s Guide

Astra LoadTest Context Sensitive Help provides immediate answers to questions that arise as you work with Astra LoadTest. It describes dialog boxes, and shows you how to perform Astra LoadTest tasks. To activate this help, click in a window and press F1. Check Mercury Interactive’s Customer Support Web site for updates to Astra LoadTest help files.

Technical Support Online uses your default Web browser to open Mercury Interactive’s Customer Support Web site. This site enables you to browse the knowledge base and add your own articles, post to and search user discussion forums, submit support requests, download patches and updated documentation, and more. The URL for this Web site is http://support.mercuryinteractive.com.

Support Information presents the locations of Mercury Interactive’s Customer Support Web site and home page, the e-mail address for sending information requests, and a list of Mercury Interactive's offices around the world.

Mercury Interactive on the Web uses your default Web browser to open Mercury Interactive's home page (http://www.mercuryinteractive.com). This site provides you with the most up-to-date information on Mercury Interactive, its products, and services. This includes new software releases, seminars and trade shows, customer support, training, and more.

Astra LoadTest Documentation Set

Astra LoadTest is supplied with a set of documentation that describes how to:

➤ install Astra LoadTest
➤ create Vuser scripts using the Virtual User Recorder
➤ use the Astra LoadTest Controller to run load test scenarios
➤ use the Astra LoadTest Analysis to analyze load test scenarios
Using the Astra LoadTest Documentation Set


Installation Guide
For instructions on installing Astra LoadTest, refer to the Astra LoadTest Installation Guide.

Controller User’s Guide
For a description of how to create and run Astra LoadTest scenarios using the Astra LoadTest Controller, refer to the Astra LoadTest Controller User's Guide. The Controller User’s Guide presents an overview of the Astra LoadTest testing process.

Analysis User’s Guide
For a description of how to use the Astra LoadTest Analysis graphs and reports after running a scenario in order to analyze system performance, refer to the Astra LoadTest Analysis User’s Guide.

Guide for Creating Vuser Scripts
The Virtual User Recorder User's Guide describes how to create Vuser scripts that you will use in your load testing.

Note: The Virtual User Recorder is also used to create functional tests for Astra QuickTest.

Throughout this guide, the use of the term script is synonymous with the term test for the Virtual User Recorder.
Typographical Conventions

This book uses the following typographical conventions:

1, 2, 3 Bold numbers indicate steps in a procedure.

➤ Bullets indicate options and features.

> The greater than sign separates menu levels (for example, File > Open).

Stone Sans The Stone Sans font indicates names of interface elements in a procedure (for example, “Click the Run button.”).

Italics Italic text indicates names (for example, names of variables or books).

Helvetica The Helvetica font is used for examples and strings that are to be typed in literally.

<> Angle brackets enclose a part of a URL address or file path that can vary (for example, http://<ALT_dir>/bin).

[ ] Square brackets enclose optional parameters.

... In a line of syntax, an ellipsis indicates that more items of the same format may be included.
Introducing Astra LoadTest Analysis

Astra LoadTest Analysis provides graphs and reports to help you analyze the performance of your system. These graphs and reports summarize the scenario execution.

This chapter describes:
➤ Creating Analysis Sessions
➤ Starting the Analysis
➤ Collating Execution Results
➤ Viewing Summary Data
➤ Aggregating Analysis Data
➤ Setting the Analysis Time Filter
➤ Setting General Options
➤ Setting Database Options
➤ Working with Templates
➤ Viewing Session Information
➤ Analysis Graphs
➤ Opening Analysis Graphs
About the Analysis

During scenario execution, Vusers generate result data as they perform their transactions. To monitor the scenario performance during test execution, use the online monitoring tools described in the Astra LoadTest Controller User’s Guide. To view a summary of the results after test execution, you can use one or more of the following tools:

➤ The Vuser log files contain a full trace of the scenario run for each Vuser. These files are located in the scenario results directory. (When you run a Vuser script in standalone mode, these files are placed in the Vuser script directory.) For more information on Vuser log files, refer to the Astra LoadTest Controller User’s Guide.

➤ The Controller Output window displays information about the scenario run. If your scenario run fails, look for debug information in this window. For more information, see the Astra LoadTest Controller User’s Guide.

➤ The Analysis graphs help you determine system performance and provide information about transactions and Vusers. You can compare multiple graphs by combining results from several scenarios or merging several graphs into one.

➤ The Graph Data and Raw Data views display the actual data used to generate the graph in a spreadsheet format. You can copy this data into external spreadsheet applications for further processing.

➤ The Report utilities enable you to view a Summary report and summary HTML report for each graph.

This chapter provides an overview of the graphs and reports that can be generated through the Analysis.
Creating Analysis Sessions

When you run a scenario, data is stored in a result file with an .lrr extension. The Analysis is the utility that processes the gathered result information and generates graphs and reports.

When you work with the Analysis utility, you work within a session. An Analysis session contains at least one set of scenario results (.lrr file). The Analysis stores the display information and layout settings for the active graphs in a file with an .lra extension.

Starting the Analysis

You can open the Analysis through the Astra LoadTest program group as an independent application, or directly from the Controller. To open the new Analysis utility as an independent application, choose Tools > Analysis from the Astra LoadTest Program Group.

To open the Analysis directly from the Controller, select Results > Analyze Results. This option is only available after running a scenario. The Analysis takes the latest result file from the current scenario, and opens a new session using these results. You can also instruct the Controller to automatically open the Analysis after it completes scenario execution by selecting Results > Auto Load Analysis.

When creating a new session, the Analysis prompts you for the result file (.lrr extension) that you wish to include in the session. To open an existing session, you specify an Analysis Session file (.lra extension).
Collating Execution Results

When you run a scenario, by default all Vuser information is stored locally on each Vuser host. After scenario execution the results are automatically collated or consolidated—results from all of the hosts are transferred to the results directory. You disable automatic collation by choosing Results > Auto Collate Results from the Controller window, to clear the check mark adjacent to the option. To manually collate results, choose Results > Collate Results. If your results have not been collated, the Analysis will automatically collate the results before generating the analysis data. For more information about collating results, see the Astra LoadTest Controller User's Guide.

Viewing Summary Data

In large scenarios, with results exceeding 100 MBs, it can take a while for the Analysis to process the data. While Astra LoadTest is processing the complete data, you can view a summary of the data collected. To view the summary data, choose Tools > Options, and select the Result Collection tab. Select Display summary data while generating complete data if you want the Analysis to process the complete data graphs while you view the summary data, or select Generate summary data only if you do not want Astra LoadTest to process the complete Analysis data.

The following graphs are not available when viewing summary data only: Rendezvous, Data Point (Sum), Web Page Breakdown, Network Monitor, and Error graphs.

Note: Some fields are not available for filtering when you are working with summary graphs.
Aggregating Analysis Data

If you choose to generate the complete Analysis data, the Analysis aggregates the data being generated using either built-in data aggregation formulas, or aggregation settings that you define. Data aggregation is necessary in order to reduce the size of the database and decrease processing time in large scenarios.

To aggregate Analysis data:

1 Select Tools > Options, and click the Result Collection tab in the Options dialog box.
Select one of the following three options:

- **Automatically aggregate data to optimize performance**: Instructs the Analysis to aggregate data using its own, built-in data aggregation formulas.

- **Automatically aggregate Web data only**: Instructs the Analysis to aggregate Web data using its own, built-in data aggregation formulas.

- **Apply user-defined aggregation**: Applies the aggregation settings you define. To define aggregation settings, click the **Aggregation Configuration** button. The Data Aggregation Configuration dialog box opens.

![Data Aggregation Configuration dialog box](image)
Select **Aggregate Data** if you want to specify the data to aggregate. Specify the type(s) of graphs for which you want to aggregate data, and the graph properties—Vuser ID, Group Name, and Script Name—you want to aggregate. If you do not want to aggregate the failed Vuser data, select **Do not aggregate failed Vusers**.

**Note:** You will not be able to drill down on the graph properties you select to aggregate.

Specify a custom granularity for the data. To reduce the size of the database, increase the granularity. To focus on more detailed results, decrease the granularity. Note that the minimum granularity is 1 second.

Select **Use granularity of xxx seconds for Web data** to specify a custom granularity for Web data. By default, the Analysis summarizes Web measurements every 5 seconds. To reduce the size of the database, increase the granularity. To focus on more detailed results, decrease the granularity.

Click **OK** to close the Data Aggregation Configuration dialog box.

3 Click **OK** in the Result Collection tab to save your settings and close the Options dialog box.

**Setting the Analysis Time Filter**

You can filter the time range of scenario data stored in the database and displayed in the Analysis graphs. This decreases the size of the database and thereby decreases processing time.
To filter the time range of scenario data:

1. Select **Tools > Options**, and click the **Result Collection** tab in the Options dialog box.

   ![Options dialog box](image)

   - **Data source**
     - Generate summary data only
     - Generate complete data only
     - Display summary while generating complete data

   - **Data Aggregation**
     - Automatically aggregate data to optimize performance
     - Automatically aggregate Web data only
     - Apply user-defined aggregation

   - **Data Time Range**
     - All of the scenario
     - Specified scenario time range

2. In the Data Time Range box, select **Specified scenario time range**.

3. Enter the beginning and end of the scenario time range you want the Analysis to display.

4. Click **OK** to save your settings and close the Options dialog box.

---

**Note:** All graphs except the Running Vusers graph will be affected by the time range settings, in both the Summary and Complete Data Analysis modes.
Setting General Options

In the General tab of the Options dialog box, you can choose whether you want dates stored and displayed in a European or U.S. format. In addition, you can select the directory location at which you want the file browser to open, and in which you want to store temporary files.

To configure General options:

1. Select Tools > Options. The Options dialog box opens, displaying the General tab.
2 In the Date Format box, select **European** to store and display dates in the European format, or **US** to store and display dates in the American format.

3 In the File Browser box, select **Open at most recently used directory** if you want the Analysis to open the file browser at the previously used directory location. Select **Open at specified directory** and enter the directory location at which you want the file browser to open, if you want the Analysis to open the file browser at a specified directory.

4 In the Temporary Storage Location box, select Use Windows temporary directory if you want the Analysis to store temporary files in your Windows temp directory. Select **Use a specified directory** and enter the directory location in which you want to save temporary files, if you want the Analysis to save temporary files in a specified directory.

**Setting Database Options**

The Database Options tab lets you specify the database in which to store Analysis session result data. In addition, you can repair and compress your Analysis results and optimize the database that may have become fragmented.
To save result data in Access database format:

1 Select **Tools > Options** to open the Options dialog box. Select the **Database** tab.

2 Choose one of the following two options:
   - To instruct Astra LoadTest to save Analysis result data in an Access 97 database format, select **Access 97**.
   - To instruct Astra LoadTest to save Analysis result data in an Access 2000 database format, select **Access 2000**.

3 Click the **Test Parameters** button to connect to the Access database and verify that the “list separator” registry options on your machine are the same as those on the database machine.
4 Click the **Compact Database** button to repair and compress results that may have become fragmented, and prevent the use of excessive disk space.

---

**Note:** Long scenarios (duration of two hours or more) will require more time for compacting.

---

**Working with Templates**

You can save the filter and display options that you specified for an Analysis session in order to use them later in another session.

**To save the Analysis template that you created:**

1 Select **Tools > Templates > Save As Template**. The Save As Template dialog box opens.

![Save As Template dialog box](image)

2 Enter the name of the template you want to create, or select the template name using the browse button to the right of text box.

3 To apply the template to any new session you open, select **Automatically apply this template to a new session**.
4 To apply the default Analysis granularity (one second) to the template, select **Use automatic granularity**. For information about setting Analysis granularity, see “Changing the Granularity of the X-Axis” on page 24.

5 To generate an HTML report using the template, select **Generate the following automatic HTML report**, and specify or select a report name. For information about generating HTML reports, see “Creating HTML Reports” on page 189.

6 To instruct the Analysis to automatically save the session using the template you specify, select **Automatically save the session as**, and specify or select a file name.

7 Click **OK** to close the dialog box and save the template.

Once you have saved a template, you can apply it to other Analysis sessions.

**To use a saved template in another Analysis session:**

1 Select **Tools > Templates > Apply/Edit Template**. The Apply/Edit Template dialog box opens.

2 Select the template you want to use from the template selector, or click the browse button to choose a template from a different location.
To apply the template to any new session you open, select **Automatically apply this template to a new session**.

To apply the default Analysis granularity (one second) to the template, select **Use automatic granularity**. For information about setting Analysis granularity, see “Changing the Granularity of the X-Axis” on page 24.

To generate an HTML report using the template, select **Generate the following automatic HTML report**, and specify or select a report name. For information about generating HTML reports, see “Creating HTML Reports” on page 189.

To instruct the Analysis to automatically save the session using the template you specify, select **Automatically save the session as**, and specify or select a file name.

Click **OK** to close the dialog box and load the template you selected into the current Analysis session.

**Viewing Session Information**

You can view the properties of the current Analysis session in the Session Information dialog box.

**To view the properties of the current Analysis session:**

Select **File > Session Information**. The Session Information dialog box opens, enabling you to view the session name, result file name, and database name, directory path, and type. In addition, you can view whether the session contains complete or summary data, whether a time filter has been applied.
to the session, and whether the data was aggregated. The Web granularity used in the session is also displayed.

**Analysis Graphs**

The Analysis graphs are divided into the following categories:

**Vuser** graphs display information about Vuser states and other Vuser statistics. For more information, see Chapter 3, “Vuser Graphs.”

**Transaction** graphs and reports provide information about transaction performance and response time. For more information, see Chapter 4, “Transaction Graphs.”

**Web Resource** graphs provide information about the throughput, hits per second, HTTP responses per second, number of retries per second, and downloaded pages per second. For more information, see Chapter 5, “Web Resource Graphs.”
**Web Page Breakdown** graphs provide information about the size and download time of each Web page component. For more information, see Chapter 6, “Web Page Breakdown Graphs.”

**User-Defined Data Point** graphs display information about the custom data points that were gathered by the online monitor. For more information, see Chapter 7, “User-Defined Data Point Graphs.”

**System Resource** graphs show statistics relating to the system resources that were monitored during the scenario using the online monitor. This category also includes graphs for SNMP and TUXEDO monitoring. For more information, see Chapter 8, “System Resource Graphs.”

**Network Monitor** graphs provide information about the network delays. For more information, see Chapter 9, “Network Monitor Graphs.”

**Firewall** graphs provide information about firewall server resource usage. For more information, see Chapter 10, “Firewall Server Monitor Graphs.”

**Web Server Resource** graphs provide information about the resource usage for the Apache, iPlanet/Netscape, and MS IIS Web servers. For more information see Chapter 11, “Web Server Resource Graphs.”

**Web Application Server Resource** graphs provide information about the resource usage for various Web application servers such as Ariba, ATG Dynamo, BroadVision, Brokat Twister, ColdFusion, Fujitsu INTERSTAGE, Microsoft ASP, Oracle9iAS HTTP, SilverStream, WebLogic (SNMP), WebLogic (JMX), and WebSphere. For more information see Chapter 12, “Web Application Server Resource Graphs.”

**Database Server Resource** graphs provide information about DB2, Oracle, and SQL Server database resources. For more information, see Chapter 13, “Database Server Resource Graphs.”

Opening Analysis Graphs

By default, Astra LoadTest displays only the Summary Report in the graph tree view. You can open the Analysis graphs using the Open a New Graph dialog box.

To open a new graph:

1. Select **Graph > Add Graph**, or click `<New Graph>` in the graph tree view. The Open a New Graph dialog box opens.

2. Click the "+" to expand the graph tree, and select a graph. You can view a description of the graph in the Graph Description box.

3. Click **Open Graph**. The Analysis generates the graph you selected and adds it to the graph tree view. The graph is displayed in the right pane of the Analysis.

To display an existing graph in the right pane of the Analysis, select the graph in the graph tree view.
The Analysis contains several utilities that allow you to customize result data and view this data in various different ways.

This chapter describes:

➤ About Working with Analysis Graphs
➤ Determining a Point’s Coordinates
➤ Performing a Drill Down on a Graph
➤ Enlarging a Section of a Graph
➤ Changing the Granularity of the X-Axis
➤ Applying a Filter to a Graph
➤ Grouping and Sorting Results
➤ Configuring Display Options
➤ Viewing the Legend
➤ Viewing the Data as a Spreadsheet and as Raw Data
➤ Viewing Measurement Trends
About Working with Analysis Graphs

The Analysis provides a number of utilities that enable you to customize the graphs in your session so that you can view the data displayed in the most effective way possible.

Using the Analysis utilities, you can determine a point’s coordinates, drill down on a graph, enlarge a section of a graph, change the granularity of a graph’s x-axis, apply a filter to a graph, group and sort result data, configure a graph’s display options, view a graph’s data as a spreadsheet or as raw data, and view measurement trends.

Determining a Point’s Coordinates

You can determine the coordinates and values at specific points in a graph. Place the cursor over the point you want to evaluate. The Analysis displays the axis values and other grouping information.
Performing a Drill Down on a Graph

The Analysis provides another filtering mechanism called *drill down*. Drill down lets you focus on a specific measurement within your graph. You select one measurement within the graph and display it according to desired grouping. The available groupings are Vuser ID, Group Name, Vuser End Status, etc. depending on the graph. For example, the **Average Transaction Response Time** graph shows one line per transaction. To determine the response time for each Vuser, you drill down on one transaction and sort it according to Vuser ID. The graph displays a separate line for each Vuser's transaction response time.

**Note:** The drill down feature is not available for the Web Page Breakdown graph.

In the following example, the graph shows a line for each of the five transactions.
In a drill down for the MainPage transaction per Vuser ID, the graph displays the response time only for the MainPage transaction, one line per Vuser.

You can see from the graph that the response time was longer for some Vusers than for others.
To drill down in a graph:

1. Right-click on a line, bar, or segment within the graph, and select **Drill Down**. The Drill Down Options dialog box opens listing all of the measurements in the graph.

2. Select a measurement for drill down.

3. From the Group By box, select a group by which to sort.

4. Click **OK**. The Analysis drills down and displays the new graph.

5. To undo the last drill down settings, choose **Undo Set Filter/Group By** from the right-click menu.

6. To perform additional drill downs, repeat steps 1 to 4.

7. To clear all filter and drill down settings, choose **Clear Filter/Group By** from the right-click menu.
**Enlarging a Section of a Graph**

Graphs initially display data representing the entire duration of the scenario. You can enlarge any section of a graph to zoom in on a specific period of the scenario run. For example, if a scenario ran for ten minutes, you can enlarge and focus on the scenario events that occurred between the second and fifth minutes.

**To zoom in on a section of the graph:**

1. Click inside a graph.
2. Move the mouse pointer to the beginning of the section you want to enlarge, but not over a line of the graph.
3. Hold down the left mouse button and draw a box around the section you want to enlarge.
4. Release the left mouse button. The section is enlarged.
5. To restore the original view, choose Clear Display Option from the right-click menu.

**Changing the Granularity of the X-Axis**

You can make the graphs easier to read and analyze by changing the granularity (scale) of the x-axis. The maximum granularity is half of the graph’s time range. To ensure readability and clarity, the Analysis automatically adjusts the minimum granularity of graphs with ranges of 500 seconds or more.
To change the granularity of a graph:

1. Click inside a graph.

2. Select View > Set Granularity, or click the Set Granularity button. The Granularity dialog box opens.

3. Enter a new granularity value in milliseconds, minutes, seconds, or hours.

4. Click OK.

In the following example, the Hits per Second graph is displayed using different granularities. The y-axis represents the number of hits per second within the granularity interval. For a granularity of 1, the y-axis shows the number of hits per second for each one second period of the scenario. For a
granularity of 5, the y-axis shows the number of hits per second for every five-second period of the scenario.

In the above graphs, the same scenario results are displayed in a granularity of 1, 5, and 10. The lower the granularity, the more detailed the results. For example, using a low granularity as in the upper graph, you see the intervals in which no hits occurred. It is useful to use a higher granularity to study the overall Vuser behavior throughout the scenario.

By viewing the same graph with a higher granularity, you can easily see that overall, there was an average of approximately 1 hit per second.
Applying a Filter to a Graph

When viewing graphs in an Analysis session, you can specify to display only the desired information. If, by default, all transactions are displayed for the entire length of the scenario, you can filter a graph to show fewer transactions for a specific segment of the scenario. For example, you can display four transactions beginning from five minutes into the scenario and ending three minutes before the end of the scenario.

The filter conditions differ for each type of graph. The filter conditions also depend on your scenario. For example, if you only had one group or one load generator machine in your scenario, the Group Name and Load Generator Name filter conditions do not apply.

You can also activate global filter conditions that will apply to all graphs in the session. The available global filter conditions are a combination of the filter conditions that apply to the individual graphs.

Note that you can also filter merged graphs. The filter conditions for each graph are displayed on separate tabs.

**To set a filter condition for an individual graph:**

1. Select the graph you want to filter by clicking the graph tab or clicking the graph name in the tree view.
2 Choose View > Set Filter/Group By. The Graph Settings dialog box opens.

3 Click the Criteria box of the condition(s) you want to set, and select either "=" or "<>" (does not equal) from the drop down list.

4 Click the Values box of the filter condition you want to set, and select a value from the drop down box. For several filter conditions, a new dialog box opens.
Chapter 2 • Working with Analysis Graphs

5 For the Transaction Response Time filter condition, the Set Dimension Information dialog box opens. Specify a minimum and maximum transaction response time for each transaction.

6 For the Vuser ID filter condition, the Vuser ID dialog box opens. Specify the Vuser IDs, or the range of Vusers, you want the graph to display.
For the Scenario Elapsed Time filter condition, the Scenario Elapsed Time dialog box opens. Specify the start and end time for the graph in hours:minutes:seconds format. The time is relative to the start of the scenario.

For Rendezvous graphs, while setting the Number of Released Vusers condition, the Set Dimension Information dialog box opens. Specify a minimum and maximum number of released Vusers.

For all graphs that measure resources (Web Server, Database Server, etc.), when you set the Resource Value condition, the Set Dimension Information dialog box opens displaying a full range of values for each resource. Specify a minimum and maximum value for the resource.

Click OK to accept the settings and close the Graph Settings dialog box.

To apply a global filter condition for all graphs in the session (both those displayed and those that have not yet been opened), choose File > Set Global Filter or click the Set Global Filter button, and set the desired filters.

Note: You can set the same filter conditions described above for the Summary Report. To set filter conditions for the Summary Report, select Summary Report in the graph tree view, and choose View > Summary Filter. Select the filter conditions you want to apply to the Summary Report in the Analysis Summary Filter dialog box.
Grouping and Sorting Results

When viewing a graph, you can group the data in several ways. For example, Transaction graphs can be grouped by the Transaction End Status. The Vuser graphs can be grouped by the Scenario Elapsed Time, Vuser End Status, Vuser Status, and VuserId.

You can also sort by more than one group—for example by Vuser ID and then Vuser status. The results are displayed in the order in which the groups are listed. You can change the order in which things are grouped by rearranging the list. The following graph shows the Transaction Summary grouped according to Vusers.

To sort the graph data according to groups:

1 Select the graph you want to sort by clicking the graph tab or clicking the graph name in the tree view.

2 Choose View > Set Filter/Group By. The Graph Settings dialog box opens.
3 In the Available Groups box, select the group by which you want to sort the results.

4 Click the right-facing arrow to move your selection to the Selected Groups box.

5 To change the order in which the results are grouped, select the group you want to move and click the up or down arrow until the groups are in the desired order.

6 To remove an existing grouping, select an item in the Selected Groups box and click the left-facing arrow to move it to the Available Groups box.

7 Click OK to close the dialog box.

**Configuring Display Options**

You can configure both standard and advanced display options for each graph. The standard options let you select the type of graph and the time setting. The advanced options allow you to modify the scale and format of each graph.

**Standard Display Options**

The standard display options let you choose the type of graph to display: line, point, bar, or pie graph. Not all options are available for all graphs.
In addition, you can indicate whether the graph should be displayed with a three-dimensional look, and specify the percent for the three-dimensional graphs. This percentage indicates the thickness of the bar, grid, or pie chart.

The standard display options also let you indicate how to plot the results that are time-based: relative to the beginning of the scenario (default), or absolute time, based on the system clock of the machine.

To open the Display Options dialog box, choose View > Display Options or click the Display Options button.

Choose a graph type, specify a three-dimensional percent, select whether you want a legend to be displayed, and/or choose a time option. Click Close to accept the settings and close the dialog box.
**Advanced Display Options**

The Advanced options let you configure the look and feel of your graph as well as its title and the format of the data. To set the Advanced options, you must first open the Display Options dialog box. Choose View > Display Options or click the Display Options button. To access the Advanced options, click Advanced. The Editing MainChart dialog box opens.

![Editing MainChart dialog box](image)

You can customize the graph layout by setting the Chart and Series preferences. Click the appropriate tab and sub-tab to configure your graph.

**Chart Settings**

The Chart settings control the look and feel of the entire graph—not the individual points. You set Chart preferences using the following tabs: Series, General, Axis, Titles, Legend, Panel, Walls, and 3D.

**Series:** displays the graph style, (bar, line, etc.) the hide/show settings, line and fill color, and the title of the series.

**General:** contains options for print preview, export, margins, scrolling, and magnification.
Chapter 2 • Working with Analysis Graphs

Axis: indicates which axes to show as well as their scales, titles, ticks, and position.

Titles: allows you to set the title of the graph, its font, background color, border, and alignment.

Legend: includes all legend-related settings, such as position, fonts, and divider lines.

Panel: shows the background panel layout of the graph. You can modify its color, set a gradient option, or specify a background image.

Walls: lets you set colors for the walls of three-dimensional graphs.

3D: contains the three-dimensional settings, offset, magnification, and rotation angle for the active graph.

Series Settings

The Series settings control the appearance of the individual points plotted in the graph. You set Series preferences using the following tabs: Format, Point, General, and Marks.

Format: allows you to set the border color, line color, pattern and invert property for the lines or bars in your graph.

Point: displays the point properties. Points appear at various points within your line graph. You can set the size, color and shape of these points.

General: contains the type of cursor, the format of the axis values, and show/hide settings for the horizontal and vertical axis.

Marks: allows you to display the value for each point in the graph and configure the format of those marks.
**Viewing the Legend**

The Legend tab displays the color, scale, minimum, maximum, average, median, and standard deviation of each measurement appearing in the graph.

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Color</th>
<th>Scale</th>
<th>Minimum</th>
<th>Maximum</th>
<th>Average</th>
<th>Median</th>
<th>Std Deviation</th>
</tr>
</thead>
<tbody>
<tr>
<td>ai_head2_pl_Actor1_159</td>
<td>1</td>
<td>0.176</td>
<td>0.195</td>
<td>0.247</td>
<td>0.19</td>
<td>0.195</td>
<td></td>
</tr>
<tr>
<td>bge_of_Action1_183</td>
<td>1</td>
<td>0.167</td>
<td>0.454</td>
<td>0.24</td>
<td>0.184</td>
<td>0.092</td>
<td></td>
</tr>
<tr>
<td>bank_pl_Actor1_167</td>
<td>1</td>
<td>0.196</td>
<td>0.812</td>
<td>0.231</td>
<td>0.2</td>
<td>0.2</td>
<td></td>
</tr>
<tr>
<td>bullet_of_Action1_234</td>
<td>1</td>
<td>0.11</td>
<td>0.245</td>
<td>0.164</td>
<td>0.17</td>
<td>0.04</td>
<td></td>
</tr>
<tr>
<td>butt_qpl_pl_Actor1_207</td>
<td>1</td>
<td>0.13</td>
<td>0.238</td>
<td>0.177</td>
<td>0.176</td>
<td>0.027</td>
<td></td>
</tr>
<tr>
<td>Click_here_Actor1_107</td>
<td>1</td>
<td>0.167</td>
<td>0.827</td>
<td>0.238</td>
<td>0.201</td>
<td>0.22</td>
<td></td>
</tr>
</tbody>
</table>

The Legend tab shortcut menu (right-click) has the following additional features:

- **Show/Hide**: Displays or hides a measurement in the graph.
- **Show only selected**: Displays the highlighted measurement only.
- **Show all**: Displays all the available measurements in the graph.
- **Configure measurements**: Opens the Measurement Options dialog box in which you can set the color and scale of the measurement you selected, and choose whether you want to view measurement trends for all the measurements in the graph.
➤ **Show measurement description:** Displays a dialog box with the name, monitor type, and description of the selected measurement.

➤ **Animate selected line:** Displays the selected measurement as a flashing line.

➤ **Sort by this column:** Sorts the measurements according to the selected column, in ascending or descending order.

➤ **Configure columns:** Opens the Legend Columns Options dialog box in which you can choose the columns you want to view, the width of each column, and the way you want to sort the columns.

➤ **Web page breakdown for** *<selected measurement>* (appears for measurements in the Average Transaction Response Time and Transaction Performance Summary graphs): Displays a Web Page Breakdown graph for the selected transaction measurement.

➤ **Break down** (appears for measurements in the Web Page Breakdown graphs): Displays a graph with a breakdown of the selected page.
Viewing the Data as a Spreadsheet and as Raw Data

The Analysis allows you to view graph data in two ways:

➤ **Spreadsheet**: The graph values displayed in the Graph Data tab.
➤ **Raw Data**: The actual raw data collected during the scenario, displayed in the Raw Data tab.

### Spreadsheet View

You can view the graph displayed by the Analysis in spreadsheet format using the **Graph Data** tab below the graph.

<table>
<thead>
<tr>
<th>Transaction Name</th>
<th>Minimum</th>
<th>Average</th>
<th>Maximum</th>
</tr>
</thead>
<tbody>
<tr>
<td>get_read_gcl_action_153</td>
<td>0.12</td>
<td>0.304</td>
<td>3.105</td>
</tr>
<tr>
<td>key_gcl_Action_153</td>
<td>0.11</td>
<td>0.27</td>
<td>1.462</td>
</tr>
<tr>
<td>book_gcl_Action_167</td>
<td>0.19</td>
<td>0.373</td>
<td>3.374</td>
</tr>
<tr>
<td>bulk_gcl_Action_224</td>
<td>0.11</td>
<td>0.184</td>
<td>0.704</td>
</tr>
<tr>
<td>bulk_art_gcl_Action_107</td>
<td>0.13</td>
<td>0.184</td>
<td>0.211</td>
</tr>
<tr>
<td>Click_here_Action_107</td>
<td>0.16</td>
<td>0.33</td>
<td>2.124</td>
</tr>
</tbody>
</table>

The first column displays the values of the x-axis. The following columns show the y-axis values for each transaction.

If there are multiple values for the y-axis, as in the Transaction Performance Summary graph (minimum, average, and maximum), all of the plotted values are displayed. If you filter out a transaction, it will not appear in the view.

The Spreadsheet shortcut menu (right-click) has the following additional features:

➤ **Copy All**: You can copy the spreadsheet to the clipboard in order to paste it into an external spreadsheet program.
➤ **Save As**: You can save the spreadsheet data to an Excel file. Once you have the data in Excel, you can generate your own customized graphs.
Raw Data View
You can view the actual raw data collected during test execution for the active graph. The Raw Data view is not available for all graphs.

Viewing the raw data can be especially useful for:

➤ determining specific details about a peak—for example, which Vuser was running the transaction that caused the peak value(s).

➤ performing a complete export of unprocessed data for your own spreadsheet application.

To display a graph’s Raw Data view:

1 Choose View > View Raw Data or click the Raw Data button. The Raw Data dialog box opens.

![Raw Data Dialog Box]

2 Specify a time range—the entire graph (default) or a specific range of time—and click OK.
3 Click the **Raw Data** tab below the graph. The Analysis displays the raw data in a grid directly below the active graph.

<table>
<thead>
<tr>
<th>Transaction Name</th>
<th>Transaction Response Time</th>
<th>Scenario Elapsed Time</th>
<th>Transaction End Status Name</th>
<th>VuserID</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dimension Desktop</td>
<td>0.25</td>
<td>18</td>
<td>Pass</td>
<td>Vuser1</td>
</tr>
<tr>
<td>Period1_1_450_MHz</td>
<td>2.274</td>
<td>15</td>
<td>Pass</td>
<td>Vuser1</td>
</tr>
<tr>
<td>Action1_Transaction</td>
<td>6.5</td>
<td>13</td>
<td>Pass</td>
<td>Vuser1</td>
</tr>
<tr>
<td>del_disco</td>
<td>1.502</td>
<td>18</td>
<td>Pass</td>
<td>Vuser1</td>
</tr>
<tr>
<td>Action1_Transaction</td>
<td>4.106</td>
<td>17</td>
<td>Pass</td>
<td>Vuser1</td>
</tr>
<tr>
<td>del_disco</td>
<td>0.17</td>
<td>13</td>
<td>Pass</td>
<td>Vuser1</td>
</tr>
</tbody>
</table>

4 To show a different range, repeat the above procedure.

**Viewing Measurement Trends**

You can view the pattern of a line graph more effectively by standardizing the graph’s y-axis values. Standardizing a graph causes the graph’s y-axis values to converge around zero. This cancels the measurements’ actual values and allows you to focus on the behavior pattern of the graph during the course of the scenario.

The Analysis standardizes the y-axis values in a graph according to the following formula:

New Y value = (Previous Y Value - Average of previous values) / STD of previous values

**To view a line graph as a standardized graph:**

1 Select **View > View Measurement Trends**, or right-click the graph and choose **View Measurement Trends**. Alternatively, you can select **View > Configure Measurements** and check the **View measurement trends for all measurements** box.
Note: The standardization feature can be applied to all line graphs except the Web Page Breakdown graph.

2 View the standardized values for the line graph you selected. Note that the values in the Minimum, Average, Maximum, and Std. Deviation legend columns are real values.

To undo the standardization of a graph, repeat step 1.

Note: If you standardize two line graphs, the two y-axes merge into one y-axis.
After running a scenario, you can check the behavior of the Vusers that participated in the scenario using the following Vuser graphs:

- Running Vusers Graph
- Vuser Summary Graph
- Rendezvous Graph

About Vuser Graphs

During scenario execution, Vusers generate data as they perform transactions. The Vuser graphs let you determine the overall behavior of Vusers during the scenario. They display the Vuser states, the number of Vusers that completed the script, and rendezvous statistics. Use these graphs in conjunction with Transaction graphs to determine the effect of the number of Vusers on transaction response time.
Running Vusers Graph

The Running Vusers graph displays the number of Vusers that executed Vuser scripts and their status during each second of the test. This graph is useful for determining the Vuser load on your server at any given moment. By default, this graph only shows the Vusers with a Run status. To view another Vuser status, set the filter conditions to the desired status. For more information, see Chapter 2, “Working with Analysis Graphs.”

The x-axis represents the elapsed time from the beginning of the scenario run. The y-axis represents the number of Vusers in the scenario.
**Vuser Summary Graph**

The Vuser Summary graph displays a summary of Vuser performance. It lets you view the number of Vusers that successfully completed the scenario run relative to those that did not.

This graph may only be viewed as a pie.
Rendezvous Graph

The Rendezvous graph indicates when Vusers were released from rendezvous points, and how many Vusers were released at each point.

This graph helps you understand transaction performance times. If you compare the Rendezvous graph to the Average Transaction Response Time graph, you can see how the load peak created by a rendezvous influences transaction times.

On the Rendezvous graph, the x-axis indicates the time that elapsed since the beginning of the scenario. The y-axis indicates the number of Vusers that were released from the rendezvous. If you set a rendezvous for 60 Vusers, and the graph indicates that only 25 were released, you can see that the rendezvous ended when the timeout expired because all of the Vusers did not arrive.
After running a scenario, you can analyze the transactions that were executed during the test using one or more of the following graphs:

- Average Transaction Response Time Graph
- Transactions per Second Graph
- Total Transactions per Second
- Transaction Summary Graph
- Transaction Performance Summary Graph
- Transaction Response Time (Under Load) Graph
- Transaction Response Time (Percentile) Graph
- Transaction Response Time (Distribution) Graph

**About Transaction Graphs**

During scenario execution, Vusers generate data as they perform transactions. The Analysis enables you to generate graphs that show the transaction performance and status throughout script execution.

You can use additional Analysis tools such as merging and crossing results to understand your transaction performance graphs. You can also sort the graph information by transactions. For more information about working with the Analysis, see Chapter 2, “Working with Analysis Graphs.”
Average Transaction Response Time Graph

The Average Transaction Response Time graph displays the average time taken to perform transactions during each second of the scenario run.

The x-axis represents the elapsed time from the beginning of the scenario run. The y-axis represents the average time (in seconds) taken to perform each transaction.

![Average Transaction Response Time Graph](image)

This graph is displayed differently for each granularity. The lower the granularity, the more detailed the results. However, it may be useful to view the results with a higher granularity to study the overall Vuser behavior throughout the scenario. For example, using a low granularity, you may see intervals when no transactions were performed. However, by viewing the same graph with a higher granularity, you will see the graph for the overall transaction response time. For more information on setting the granularity, see Chapter 2, “Working with Analysis Graphs.”

Note: By default, only transactions that passed are displayed.
Chapter 4 • Transaction Graphs

You can view a breakdown of a transaction in the Average Transaction Response Time graph by selecting **View > Show Transaction Breakdown Tree**, or right-clicking the transaction and selecting **Show Transaction Breakdown Tree**. In the Transaction Breakdown Tree, right-click the transaction you want to break down, and select **Break Down <transaction name>**. The Average Transaction Response Time graph displays data for the sub-transactions.

To view a breakdown of the Web page(s) included in a transaction or sub-transaction, right-click it and select **Web page breakdown for <transaction name>**. For more information on the Web Page Breakdown graphs, see Chapter 6, “Web Page Breakdown Graphs.”

You can compare the Average Transaction Response Time graph to the Running Vusers graph to see how the number of running Vusers affects the transaction performance time.

For example, if the Average Transaction Response Time graph shows that performance time gradually improved, you can compare it to the Running Vusers graph to see whether the performance time improved due to a decrease in the Vuser load.

If you have defined acceptable minimum and maximum transaction performance times, you can use this graph to determine whether the performance of the server is within the acceptable range.
Transactions per Second Graph

The Transactions per Second graph displays, for each transaction, the number of times it passed, failed, and stopped during each second of a scenario run. This graph helps you determine the actual transaction load on your system at any given moment. You can compare this graph to the Average Transaction Response Time graph in order to analyze the effect of the number of transactions on the performance time.

The x-axis represents the elapsed time from the beginning of the scenario run. The y-axis represents the number of transactions performed during the scenario run.
Total Transactions per Second

The Total Transactions per Second graph displays the total number of transactions that passed, the total number of transactions that failed, and the total number of transactions that were stopped, during each second of a scenario run.

The x-axis represents the elapsed time (in seconds) since the start of the scenario run. The y-axis represents the total number of transactions performed during the scenario run.
**Transaction Summary Graph**

The Transaction Summary graph summarizes the number of transactions in the scenario that failed, passed, stopped, and ended in error.

The x-axis specifies the name of the transaction. The y-axis shows the number of transactions performed during the scenario run.
**Transaction Performance Summary Graph**

The Transaction Performance Summary graph displays the minimum, maximum and average performance time for all the transactions in the scenario.

The x-axis specifies the name of the transaction. The y-axis shows the time—rounded off to the nearest second—taken to perform each transaction.

![Transaction Performance Summary Graph](image)

You can view a breakdown of a transaction in the Transaction Performance Summary graph by selecting View > Show Transaction Breakdown Tree, or right-clicking the transaction and selecting Show Transaction Breakdown Tree. In the Transaction Breakdown Tree, right-click the transaction you want to break down, and select Break Down <transaction name>. The Transaction Performance Summary graph displays data for the sub-transactions.

To view a breakdown of the Web page(s) included in a transaction or sub-transaction, right-click it and select Web page breakdown for <transaction name>. For more information on the Web Page Breakdown graphs, see Chapter 6, “Web Page Breakdown Graphs.”
**Transaction Response Time (Under Load) Graph**

The Transaction Response Time (Under Load) graph is a combination of the Running Vusers and Average Transaction Response Time graphs and indicates transaction times relative to the number of Vusers running at any given point during the scenario. This graph helps you view the general impact of Vuser load on performance time and is most useful when analyzing a scenario with a gradual load. For information about creating a gradual load for a scenario, see the *Astra LoadTest Controller User’s Guide*.

The x-axis indicates the number of running Vusers, and the y-axis indicates the average transaction time in seconds.

![Transaction Response Time - Under Load](image)
Transaction Response Time (Percentile) Graph

The Transaction Response Time (Percentile) graph analyzes the percentage of transactions that were performed within a given time range. This graph helps you determine the percentage of transactions that met the performance criteria defined for your system. In many instances, you need to determine the percent of transactions with an acceptable response time. The maximum response time may be exceptionally long, but if most transactions have acceptable response times, the overall system is suitable for your needs.

The x-axis represents the percentage of the total number of transactions measured during the scenario run. The y-axis represents the time taken to perform the transactions.

**Note:** The Analysis approximates the transaction response time for each available percentage of transactions. The y-axis values, therefore, may not be exact.

In the following graph, fewer than 20 percent of the `tr_matrix_movie` transactions had a response time less than 70 seconds.
It is recommended to compare the Percentile graph to a graph indicating average response time such as the Average Transaction Response Time graph. A high response time for several transactions may raise the overall average. However, if the transactions with a high response time occurred less than five percent of the time, that factor may be insignificant.

**Transaction Response Time (Distribution) Graph**

The Transaction Response Time (Distribution) graph displays the distribution of the time taken to perform transactions in a scenario. If you compare it to the Transaction Performance Summary graph, you can see how the average performance was calculated.

The x-axis represents the transaction response time. The y-axis represents the number of transactions executed during the scenario.

In the following graph, most of the transactions had a response time of less than 20 seconds.
Note: This graph can only be displayed as a bar graph.

If you have defined acceptable minimum and maximum transaction performance times, you can use this graph to determine whether the performance of the server is within the acceptable range.
5

Web Resource Graphs

After a scenario run, you use the Web Resource graphs to analyze Web server performance.

This chapter describes:

➤ Hits per Second Graph
➤ Throughput Graph
➤ HTTP Status Code Summary Graph
➤ HTTP Responses per Second Graph
➤ Pages Downloaded per Second Graph
➤ Retries per Second Graph
➤ Retries Summary Graph

About Web Resource Graphs

Web Resource graphs provide you with information about the performance of your Web server. You use the Web Resource graphs to analyze the throughput on the Web server, the number of hits per second that occurred during the scenario, the number of HTTP responses per second, the HTTP status codes (which indicate the status of HTTP requests, for example, “the request was successful,” “the page was not found”) returned from the Web server, the number of downloaded pages per second, the number of server retries per second, and a summary of the server retries during the scenario.
**Hits per Second Graph**

The Hits per Second graph shows the number of HTTP requests made by Vusers to the Web server during each second of the scenario run. This graph helps you evaluate the amount of load Vusers generate, in terms of the number of hits. You can compare this graph to the Average Transaction Response Time graph to see how the number of hits affects transaction performance.

![Hits per Second Graph](image)

The x-axis represents the elapsed time since the start of the scenario run. The y-axis represents the number of hits on the server. For example, the graph above shows that the most hits per second took place during the fifty-fifth second of the scenario.

---

**Note:** You cannot change the granularity of the x-axis to a value that is less than the Web granularity you defined in the General tab of the Options dialog box.
Throughput Graph

The Throughput graph shows the amount of throughput on the server during each second of the scenario run. Throughput is measured in bytes and represents the amount of data that the Vusers received from the server at any given second. This graph helps you evaluate the amount of load Vusers generate, in terms of server throughput. You can compare this graph to the Average Transaction Response Time graph to see how the throughput affects transaction performance.

The x-axis represents the elapsed time since the start of the scenario run. The y-axis represents the throughput of the server, in bytes.

The following graph shows the highest throughput to be 193,242 bytes during the fifty-fifth second of the scenario.

**Note:** You cannot change the granularity of the x-axis to a value that is less than the Web granularity you defined in the General tab of the Options dialog box.
HTTP Status Code Summary Graph

The HTTP Status Code Summary Graph shows the number of HTTP status codes (which indicate the status of HTTP requests, for example, “the request was successful,” “the page was not found”) returned from the Web server during the scenario run, grouped by status code. Use this graph together with the HTTP Responses per Second Graph to locate those scripts which generated error codes.

This graph may only be viewed as a pie.

The following graph shows that only the HTTP status codes 200 and 302 were generated. Status code 200 was generated 1,100 times, and status code 302 was generated 125 times.
HTTP Responses per Second Graph

The HTTP Responses per Second graph shows the number of HTTP status codes (which indicate the status of HTTP requests, for example, “the request was successful,” “the page was not found”) returned from the Web server during each second of the scenario run, grouped by status code. You can group the results shown in this graph by script (using the "Group By" function) to locate scripts which generated error codes. For more information on the "Group By" function, see Chapter 2, “Working with Analysis Graphs.”

The x-axis represents the time that has elapsed since the start of the scenario run. The y-axis represents the number of HTTP responses per second.

The following graph shows that the greatest number of 200 status codes, 60, was generated in the fifty-fifth second of the scenario run. The greatest number of 302 codes, 8.5, was generated in the fiftieth second of the scenario run.
The following table displays a list of HTTP status codes:

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>200</td>
<td>OK</td>
</tr>
<tr>
<td>201</td>
<td>Created</td>
</tr>
<tr>
<td>202</td>
<td>Accepted</td>
</tr>
<tr>
<td>203</td>
<td>Non-Authoritative Information</td>
</tr>
<tr>
<td>204</td>
<td>No Content</td>
</tr>
<tr>
<td>205</td>
<td>Reset Content</td>
</tr>
<tr>
<td>206</td>
<td>Partial Content</td>
</tr>
<tr>
<td>207</td>
<td>Temporary Redirect</td>
</tr>
<tr>
<td>300</td>
<td>Multiple Choices</td>
</tr>
<tr>
<td>301</td>
<td>Moved Permanently</td>
</tr>
<tr>
<td>302</td>
<td>Found</td>
</tr>
<tr>
<td>303</td>
<td>See Other</td>
</tr>
<tr>
<td>304</td>
<td>Not Modified</td>
</tr>
<tr>
<td>305</td>
<td>Use Proxy</td>
</tr>
<tr>
<td>307</td>
<td>Temporary Redirect</td>
</tr>
<tr>
<td>400</td>
<td>Bad Request</td>
</tr>
<tr>
<td>401</td>
<td>Unauthorized</td>
</tr>
<tr>
<td>402</td>
<td>Payment Required</td>
</tr>
<tr>
<td>403</td>
<td>Forbidden</td>
</tr>
<tr>
<td>404</td>
<td>Not Found</td>
</tr>
<tr>
<td>405</td>
<td>Method Not Allowed</td>
</tr>
<tr>
<td>406</td>
<td>Not Acceptable</td>
</tr>
<tr>
<td>407</td>
<td>Proxy Authentication Required</td>
</tr>
<tr>
<td>408</td>
<td>Request Timeout</td>
</tr>
<tr>
<td>409</td>
<td>Conflict</td>
</tr>
</tbody>
</table>
### Code | Description
--- | ---
410 | Gone
411 | Length Required
412 | Precondition Failed
413 | Request Entity Too Large
414 | Request - URI Too Large
415 | Unsupported Media Type
416 | Requested range not satisfiable
417 | Expectation Failed
500 | Internal Server Error
501 | Not Implemented
502 | Bad Gateway
503 | Service Unavailable
504 | Gateway Timeout
505 | HTTP Version not supported

For more information on the above status codes and their descriptions, see [http://www.w3.org/Protocols/rfc2616/rfc2616-sec10.html#sec10](http://www.w3.org/Protocols/rfc2616/rfc2616-sec10.html#sec10).
Pages Downloaded per Second Graph

The Pages Downloaded per Second graph shows the number of Web pages (y-axis) downloaded from the server during each second of the scenario run (x-axis). This graph helps you evaluate the amount of load Vusers generate, in terms of the number of pages downloaded.

The following graph shows that the greatest number of pages downloaded per second, about 7, occurred in the fiftieth second of the scenario run.

Like throughput, downloaded pages per second is a representation of the amount of data that the Vusers received from the server at any given second. However, the Throughput graph takes into account each resource and its size (for example, the size of each .gif file, the size of each Web page). The Pages Downloaded per Second graph takes into account only the number of pages.
In the following example, the Throughput graph is merged with the Pages Downloaded per Second graph. It is apparent from the graph that throughput is not completely proportional to the number of pages downloaded per second. For example, between 10 and 25 seconds into the scenario run, the number of pages downloaded per second increased while the throughput decreased.
Retries per Second Graph

The Retries per Second graph displays the number of attempted server connections during each second of the scenario run. A server connection is retried when the initial connection was unauthorized, when proxy authentication is required, when the initial connection was closed by the server, when the initial connection to the server could not be made, or when the server was initially unable to resolve the load generator's IP address.

The x-axis displays the time that has elapsed since the start of the scenario run. The y-axis displays the number of server retries per second.

The following graph shows that during the first second of the scenario, the number of retries was 0.4, whereas in the fifth second of the scenario, the number of retries per second rose to 0.8.
Retries Summary Graph

The Retries Summary Graph shows the number of attempted server connections during the scenario run, grouped by the cause of the retry. Use this graph together with the Retries per Second Graph to determine at what point during the scenario the server retries were attempted.

This graph may only be viewed as a pie.

The following graph shows that the server's inability to resolve the load generator's IP address was the leading cause of server retries during the scenario run.
Web Page Breakdown Graphs

The Web Page Breakdown graphs enable you to assess whether transaction response times were affected by page content. Using the Web Page Breakdown graphs, you can analyze problematic elements—for example, images that download slowly, or broken links—of a Web site.

This chapter describes:

➤ Activating the Web Page Breakdown Graphs
➤ Page Component Breakdown Graph
➤ Page Component Breakdown (Over Time) Graph
➤ Page Download Time Breakdown Graph
➤ Page Download Time Breakdown (Over Time) Graph
➤ Time to First Buffer Breakdown Graph
➤ Time to First Buffer Breakdown (Over Time) Graph
➤ Downloaded Component Size Graph
About Web Page Breakdown Graphs

Web Page Breakdown graphs provide you with performance information for each monitored Web page in your script. You can view the download time of each page in the script and its components, and identify at what point during download time problems occurred. In addition, you can view the relative download time and size of each page and its components. The Analysis displays both average download time and download time over time data.

You correlate the data in the Web Page Breakdown graphs with data in the Transaction Performance Summary and Average Transaction Response Time graphs in order to analyze why and where problems are occurring, and whether the problems are network- or server-related.

In order for the Analysis to generate Web Page Breakdown graphs, you must enable the component breakdown feature before recording your script.

To enable the component breakdown feature:

1. From the Controller menu, choose **Tools > Options**.

2. Select the **Web Page Breakdown** tab. Select the **Enable Web Page Breakdown** check box.

For more information on recording Vuser scripts, see the *Virtual User Recorder* guide.
Activating the Web Page Breakdown Graphs

The Web Page Breakdown graphs are most commonly used to analyze a problem detected in the Transaction Performance Summary or Average Transaction Response Time graphs. For example, the Average Transaction Response Time graph below demonstrates that the average transaction response time for the trans1 transaction was high.

Using the Web Page Breakdown graphs, you can pinpoint the cause of the delay in response time for the trans1 transaction.
To view a breakdown of a transaction:


2 In the Web Page Breakdown tree, right-click the problematic page you want to break down, and select Break Down <component name>. Alternatively, select a page in the Select Page to Break Down box. The Web Page Breakdown graph for that page appears.

Note: You can open a browser displaying the problematic page by right-clicking the page in the Web Page Breakdown tree and selecting View page in browser.

3 Select one of the four available options:

➤ Download Time Breakdown: Displays a table with a breakdown of the selected page's download time. The size of each page component (including the component's header) is displayed. See the Page Download Time Breakdown Graph for more information about this display.

➤ Component Breakdown (Over Time): Displays the Page Component Breakdown (Over Time) Graph for the selected Web page.

➤ Download Time Breakdown (Over Time): Displays the Page Download Time Breakdown (Over Time) Graph for the selected Web page.

➤ Time to First Buffer Breakdown (Over Time): Displays the Time to First Buffer Breakdown (Over Time) Graph for the selected Web page.

See the following sections for an explanation of each of these four graphs.

To display the graphs in full view, click the Open graph in full view button. Note that you can also access these graphs, as well as additional Web Page Breakdown graphs, from the Open a New Graph dialog box.
Page Component Breakdown Graph

The Page Component Breakdown graph displays the average download time (in seconds) for each Web page and its components. For example, the following graph demonstrates that the main cnn.com URL took 28.64% of the total download time, compared to 35.67% for the www.cnn.com/WEATHER component.

To ascertain which components caused the delay in download time, you can break down the problematic URL by double-clicking it in the Web Page.
Breakdown tree. In the following example, the cnn.com/WEATHER component is broken down.

The above graph shows that the main cnn.com/WEATHER component took the longest time to download (8.98% of the total download time). To isolate other problematic components of the URL, it may be helpful to sort the legend according to the average number of seconds taken to download a component. To sort the legend by average, click the **Graph’s Average** column heading.

**Note:** The Page Component Breakdown graph can only be viewed as a pie.
The Page Component Breakdown (Over Time) graph displays the average response time (in seconds) for each Web page and its components during each second of the scenario run. For example, the following graph demonstrates that the response time for Satellite_Action1_963 was significantly greater, throughout the scenario, than the response time for main_js_Action1_938.
To ascertain which components were responsible for the delay in response time, you can break down the problematic component by double-clicking it in the Web Page Breakdown tree.

Using the above graph, you can track which components of the main component were most problematic, and at which point(s) during the scenario the problem(s) occurred. To isolate the most problematic components, it may be helpful to sort the legend tab according to the average number of seconds taken to download a component. To sort the legend by average, double-click the **Average** column heading.

To identify a component in the graph, you can click it. The corresponding line in the legend tab is selected.
Page Download Time Breakdown Graph

The Page Download Time Breakdown graph displays a breakdown of each page component’s download time, enabling you to determine whether slow response times are being caused by network or server errors during Web page download.

The Page Download Time Breakdown graph breaks down each component by DNS resolution time, connection time, time to first buffer, SSL.
handshaking time, receive time, FTP authentication time, client time, and error time. These breakdowns are described below:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DNS Resolution</td>
<td>Displays the amount of time needed to resolve the DNS name to an IP address, using the closest DNS server. The DNS Lookup measurement is a good indicator of problems in DNS resolution, or problems with the DNS server.</td>
</tr>
<tr>
<td>Connection</td>
<td>Displays the amount of time needed to establish an initial connection with the Web server hosting the specified URL. The connection measurement is a good indicator of problems along the network. It also indicates whether the server is responsive to requests.</td>
</tr>
</tbody>
</table>
| First Buffer        | Displays the amount of time that passes from the initial HTTP request (usually GET) until the first buffer is successfully received back from the Web server. The first buffer measurement is a good indicator of Web server delay as well as network latency.  
  
  **Note:** Since the buffer size may be up to 8K, the first buffer might also be the time it takes to completely download the element. |
| SSL Handshaking     | Displays the amount of time taken to establish an SSL connection (includes the client hello, server hello, client public key transfer, server certificate transfer, and other—partially optional—stages). After this point, all the communication between the client and server is encrypted. The SSL Handshaking measurement is only applicable for HTTPS communications. |
Note: Each measurement displayed on the page level is the sum of that measurement recorded for each page component. For example, the Connection Time for www.cnn.com is the sum of the Connection Time for each of the page's components.

The above graph demonstrates that receive time, connection time, and first buffer time accounted for a large portion of the time taken to download the main cnn.com URL. If you break the cnn.com URL down further, you can
isolate the components with the longest download time, and analyze the network or server problems that contributed to the delay in response time.

Breaking down the cnn.com URL demonstrates that for the component with the longest download time (the www.cnn.com component), the receive time accounted for a large portion of the download time.
Page Download Time Breakdown (Over Time) Graph

The Page Download Time Breakdown (Over Time) graph displays a breakdown of each page component’s download time during each second of the scenario run. This graph enables you to determine at what point during scenario execution network or server problems occurred.

**Note:** Each measurement displayed on the page level is the sum of that measurement recorded for each page component. For example, the Connection Time for www.cnn.com is the sum of the Connection Time for each of the page’s components.

To isolate the most problematic components, you can sort the legend tab according to the average number of seconds taken to download a component. To sort the legend by average, double-click the **Average** column heading.

To identify a component in the graph, click it. The corresponding line in the legend tab is selected.

In the example in the previous section, it is apparent that cnn.com was the most problematic component. If you examine the cnn.com component, the
Page Download Time Breakdown (Over Time) graph demonstrates that first buffer and receive time remained high throughout the scenario, and that DNS Resolution time decreased during the scenario.

**Note:** When the Page Download Time Breakdown (Over Time) graph is selected from the Web Page Breakdown graph, it appears as an area graph.
Time to First Buffer Breakdown Graph

The Time to First Buffer Breakdown graph displays each Web page component’s relative server/network time (in seconds) for the period of time until the first buffer is successfully received back from the Web server. If the download time for a component is high, you can use this graph to determine whether the problem is server- or network-related.

Note: Each measurement displayed on the page level is the sum of that measurement recorded for each page component. For example, the network time for www.cnn.com is the sum of the network time for each of the page’s components.

Network time is defined as the average amount of time that passes from the moment the first HTTP request is sent until receipt of ACK.

Server time is defined as the average amount of time that passes from the receipt of ACK of the initial HTTP request (usually GET) until the first buffer is successfully received back from the Web server.

In the above graph, it is apparent that network time is greater than server time.
Note: Because server time is being measured from the client, network time may influence this measurement if there is a change in network performance from the time the initial HTTP request is sent until the time the first buffer is sent. The server time displayed, therefore, is estimated server time and may be slightly inaccurate.

The graph can only be viewed as a bar graph.

You can break the main cnn.com URL down further to view the time to first buffer breakdown for each of its components.

![Graph showing Time to First Buffer Breakdown](image)

It is apparent that for the main cnn.com component (the first component on the right), the time to first buffer breakdown is almost all network time.
Time to First Buffer Breakdown (Over Time) Graph

The Time to First Buffer Breakdown (Over Time) graph displays each Web page component’s server and network time (in seconds) during each second of the scenario run, for the period of time until the first buffer is successfully received back from the Web server. You can use this graph to determine when during the scenario run a server- or network-related problem occurred.

Network time is defined as the average amount of time that passes from the moment the first HTTP request is sent until receipt of ACK.

Server time is defined as the average amount of time that passes from the receipt of ACK of the initial HTTP request (usually GET) until the first buffer is successfully received back from the Web server.

Because server time is being measured from the client, network time may influence this measurement if there is a change in network performance from the time the initial HTTP request is sent until the time the first buffer is sent. The server time displayed, therefore, is estimated server time and may be slightly inaccurate.
**Note:** Each measurement displayed on the page level is the sum of that measurement recorded for each page component. For example, the network time for www.cnn.com is the sum of the network time for each of the page’s components.

You can break the main cnn.com URL down further to view the time to first buffer breakdown for each of its components.

**Note:** When the Time to First Buffer Breakdown (Over Time) graph is selected from the Web Page Breakdown graph, it appears as an area graph.
**Downloaded Component Size Graph**

The Downloaded Component Size graph displays the size of each Web page component. For example, the following graph shows that the www.cnn.com/WEATHER component is 39.05% of the total size, whereas the main cnn.com component is 34.56% of the total size.

![Downloaded Component Size (KB)](image)

**Note:** The Web page size is a sum of the sizes of each of its components.
You can break the main cnn.com URL down further to view the size of each of its components.

In the above example, the cnn.com component’s size (20.83% of the total size) may have contributed to the delay in its downloading. To reduce download time, it may help to reduce the size of this component.

---

**Note:** The Downloaded Component Size graph can only be viewed as a pie graph.
7

User-Defined Data Point Graphs

After a scenario run, you can use the User-Defined Data Point graphs to display the values of user-defined data points in the Vuser script.

This chapter describes the:

➤ Data Points (Sum) Graph
➤ Data Points (Average) Graph

About User-Defined Data Point Graphs

The User-Defined Data Point graphs display the values of user-defined data points. You define a data point in your Vuser script by inserting a step in the following syntax at the appropriate place.

```
Services.UserDataPoint(Value,Name)
```

Data point information is gathered each time the script executes the UserDataPoint step. For more information about data points, see the online Astra LoadTest Function Reference.
Data Points (Sum) Graph

The Data Points (Sum) graph shows the sum values for user-defined data points during the scenario run.

The x-axis represents the number of seconds that elapsed since the start time of the run. The y-axis displays the sum values of the recorded data point statements.

In the following example, the `user_data_point_val_1` data point is shown as a function of the elapsed scenario time.
**Data Points (Average) Graph**

The Data Points (Average) graph shows the average values that were recorded for user-defined data points during the scenario run.

The x-axis represents the number of seconds that elapsed since the start time of the run. The y-axis displays the average values of the recorded data point statements.

In the following example, the `user_data_point_val_1` data point is shown as a function of the elapsed scenario time.
System Resource Graphs

After running a scenario, you can check the various system resources that were monitored during the scenario using one or more of the following System Resource graphs:

➤ Windows Resources Graph
➤ UNIX Resources Graph
➤ SNMP Resources Graph
➤ TUXEDO Resources Graph

About System Resource Graphs

System Resource graphs display the system resource usage measured by the online monitors during the scenario run. These graphs require that you specify the resources you want to measure before running the scenario. For more information, see the section on online monitors in the Astra LoadTest Controller User’s Guide.

System Resource graphs are available for:

➤ Windows Resources
➤ UNIX Resources
➤ SNMP Resources
➤ TUXEDO Resources
**Windows Resources Graph**

The Windows Resources graph shows the NT and Windows 2000 resources measured during the scenario. The NT and Windows 2000 measurements correspond to the built-in counters available from the Windows Performance Monitor.
The following default measurements are available for Windows Resources:

<table>
<thead>
<tr>
<th>Object</th>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>System</td>
<td>% Total Processor Time</td>
<td>The average percentage of time that all the processors on the system are busy executing non-idle threads. On a multi-processor system, if all processors are always busy, this is 100%, if all processors are 50% busy this is 50% and if 1/4th of the processors are 100% busy this is 25%. It can be viewed as the fraction of the time spent doing useful work. Each processor is assigned an Idle thread in the Idle process which consumes those unproductive processor cycles not used by any other threads.</td>
</tr>
<tr>
<td>Processor</td>
<td>% Processor Time (Windows 2000)</td>
<td>The percentage of time that the processor is executing a non-idle thread. This counter was designed as a primary indicator of processor activity. It is calculated by measuring the time that the processor spends executing the thread of the idle process in each sample interval, and subtracting that value from 100%. (Each processor has an idle thread which consumes cycles when no other threads are ready to run.) It can be viewed as the percentage of the sample interval spent doing useful work. This counter displays the average percentage of busy time observed during the sample interval. It is calculated by monitoring the time the service was inactive, and then subtracting that value from 100%.</td>
</tr>
<tr>
<td>System</td>
<td>File Data Operations/sec</td>
<td>The rate at which the computer issues read and write operations to file system devices. This does not include File Control Operations.</td>
</tr>
</tbody>
</table>
**System** | **Processor Queue Length** | The instantaneous length of the processor queue in units of threads. This counter is always 0 unless you are also monitoring a thread counter. All processors use a single queue in which threads wait for processor cycles. This length does not include the threads that are currently executing. A sustained processor queue length greater than two generally indicates processor congestion. This is an instantaneous count, not an average over the time interval.

**Memory** | **Page Faults/sec** | This is a count of the page faults in the processor. A page fault occurs when a process refers to a virtual memory page that is not in its Working Set in the main memory. A page fault will not cause the page to be fetched from disk if that page is on the standby list (and hence already in main memory), or if it is in use by another process with which the page is shared.

**PhysicalDisk** | **% Disk Time** | The percentage of elapsed time that the selected disk drive is busy servicing read or write requests.

**Memory** | **Pool Nonpaged Bytes** | The number of bytes in the nonpaged pool, a system memory area where space is acquired by operating system components as they accomplish their appointed tasks. Nonpaged pool pages cannot be paged out to the paging file. They remain in main memory as long as they are allocated.
## System Resource Graphs

<table>
<thead>
<tr>
<th>Object</th>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Memory</td>
<td>Pages/sec</td>
<td>The number of pages read from the disk or written to the disk to resolve memory references to pages that were not in memory at the time of the reference. This is the sum of Pages Input/sec and Pages Output/sec. This counter includes paging traffic on behalf of the system cache to access file data for applications. This value also includes the pages to/from non-cached mapped memory files. This is the primary counter to observe if you are concerned about excessive memory pressure (that is, thrashing), and the excessive paging that may result.</td>
</tr>
<tr>
<td>System</td>
<td>Total Interrupts/sec</td>
<td>The rate at which the computer is receiving and servicing hardware interrupts. The devices that can generate interrupts are the system timer, the mouse, data communication lines, network interface cards, and other peripheral devices. This counter provides an indication of how busy these devices are on a computer-wide basis. See also Processor:Interrupts/sec.</td>
</tr>
<tr>
<td>Objects</td>
<td>Threads</td>
<td>The number of threads in the computer at the time of data collection. Notice that this is an instantaneous count, not an average over the time interval. A thread is the basic executable entity that can execute instructions in a processor.</td>
</tr>
<tr>
<td>Process</td>
<td>Private Bytes</td>
<td>The current number of bytes that the process has allocated that cannot be shared with other processes.</td>
</tr>
</tbody>
</table>
**UNIX Resources Graph**

The UNIX Resources graph shows the UNIX resources measured during the scenario. The UNIX measurements include those available by the `rstatd` daemon: average load, collision rate, context switch rate, CPU utilization, incoming packets error rate, incoming packets rate, interrupt rate, outgoing packets error rate, outgoing packets rate, page-in rate, page-out rate, paging rate, swap-in rate, swap-out rate, system mode CPU utilization, and user mode CPU utilization.

The following default measurements are available for UNIX machines:

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Average load</td>
<td>Average number of processes simultaneously in ‘Ready’ state during the last minute</td>
</tr>
<tr>
<td>Collision rate</td>
<td>Collisions per second detected on the Ethernet</td>
</tr>
<tr>
<td>Context switches rate</td>
<td>Number of switches between processes or threads, per second</td>
</tr>
<tr>
<td>CPU utilization</td>
<td>Percent of time that the CPU is utilized</td>
</tr>
<tr>
<td>Disk rate</td>
<td>Rate of disk transfers</td>
</tr>
<tr>
<td>Measurement</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------------</td>
<td>-------------------------------------------------------------------</td>
</tr>
<tr>
<td>Incoming packets error rate</td>
<td>Errors per second while receiving Ethernet packets</td>
</tr>
<tr>
<td>Incoming packets rate</td>
<td>Incoming Ethernet packets per second</td>
</tr>
<tr>
<td>Interrupt rate</td>
<td>Number of device interrupts per second</td>
</tr>
<tr>
<td>Outgoing packets errors rate</td>
<td>Errors per second while sending Ethernet packets</td>
</tr>
<tr>
<td>Outgoing packets rate</td>
<td>Outgoing Ethernet packets per second</td>
</tr>
<tr>
<td>Page-in rate</td>
<td>Number of pages read to physical memory, per second</td>
</tr>
<tr>
<td>Page-out rate</td>
<td>Number of pages written to pagefile(s) and removed from physical memory, per second</td>
</tr>
<tr>
<td>Paging rate</td>
<td>Number of pages read to physical memory or written to pagefile(s), per second</td>
</tr>
<tr>
<td>Swap-in rate</td>
<td>Number of processes being swapped</td>
</tr>
<tr>
<td>Swap-out rate</td>
<td>Number of processes being swapped</td>
</tr>
<tr>
<td>System mode CPU utilization</td>
<td>Percent of time that the CPU is utilized in system mode</td>
</tr>
<tr>
<td>User mode CPU utilization</td>
<td>Percent of time that the CPU is utilized in user mode</td>
</tr>
</tbody>
</table>
The SNMP Resources graph shows statistics for machines running an SNMP agent, using the Simple Network Management Protocol (SNMP).

The following graph displays SNMP measurements for a machine called bonaparte:
**TUXEDO Resources Graph**

The TUXEDO Resources graph provides information about the server, load generator machine, workstation handler, and queue in a TUXEDO system.

![Graph showing TUXEDO Resources](image)

The following table lists the available TUXEDO monitor measurements:

<table>
<thead>
<tr>
<th>Monitor</th>
<th>Measurements</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Server</strong></td>
<td><strong>Requests per second</strong> - How many server requests were handled per second</td>
</tr>
<tr>
<td></td>
<td><strong>Workload per second</strong> - The workload is a weighted measure of the server requests. Some requests could have a different weight than others. By default, the workload is always 50 times the number of requests.</td>
</tr>
<tr>
<td><strong>Machine</strong></td>
<td><strong>Workload completed per second</strong> - The total workload on all the servers for the machine that was completed, per unit time</td>
</tr>
<tr>
<td></td>
<td><strong>Workload initiated per second</strong> - The total workload on all the servers for the machine that was initiated, per unit time</td>
</tr>
</tbody>
</table>
### Monitor Measurements

<table>
<thead>
<tr>
<th>Monitor</th>
<th>Measurements</th>
</tr>
</thead>
<tbody>
<tr>
<td>Queue</td>
<td><strong>Bytes on queue</strong> - The total number of bytes for all the messages waiting in the queue</td>
</tr>
<tr>
<td></td>
<td><strong>Messages on queue</strong> - The total number of requests that are waiting on queue. By default this is 0.</td>
</tr>
<tr>
<td>Workstation Handler (WSH)</td>
<td><strong>Bytes received per second</strong> - The total number of bytes received by the workstation handler, per unit time</td>
</tr>
<tr>
<td></td>
<td><strong>Bytes sent per second</strong> - The total number of bytes sent back to the clients by the workstation handler, per unit time</td>
</tr>
<tr>
<td></td>
<td><strong>Messages received per second</strong> - The number of messages received by the workstation handler, per unit time</td>
</tr>
<tr>
<td></td>
<td><strong>Messages sent per second</strong> - The number of messages sent back to the clients by the workstation handler, per unit time</td>
</tr>
<tr>
<td></td>
<td><strong>Number of queue blocks per second</strong> - The number of times the queue for the workstation handler blocked, per unit time. This gives an idea of how often the workstation handler was overloaded.</td>
</tr>
</tbody>
</table>
Network Monitor Graphs

You can use Network graphs to determine whether your network is causing a delay in the scenario. You can also determine the problematic network segment.

This chapter describes:

➤ Understanding Network Monitoring
➤ Network Delay Time Graph
➤ Network Sub-Path Time Graph
➤ Network Segment Delay Graph
➤ Verifying the Network as a Bottleneck

About Network Monitoring

Network configuration is a primary factor in the performance of Web systems. A poorly designed network can slow client activity to unacceptable levels.

In a Web system, there are many network segments. A single network segment with poor performance can affect the entire system.

Network graphs let you locate the network-related problem so that it can be fixed.
Understanding Network Monitoring

The following diagram shows a typical network. In order to go from the server machine to the Vuser machine, data must travel over several segments.

![Network Diagram]

To measure network performance, the Network monitor sends packets of data across the network. When a packet returns, the monitor calculates the time it takes for the packet to go to the requested node and return. The Network Sub-Path Time graph displays the delay from the source machine to each node along the path. The Network Segment Delay graph displays the delay for each segment of the path. The Network Delay Time graph displays the delay for the complete path between the source and destination machines.

Using the Network Monitor graphs, you can determine whether the network is causing a bottleneck. If the problem is network-related, you can locate the problematic segment so that it can be fixed.

In order for the Analysis to generate Network monitor graphs, you must activate the Network monitor before executing the scenario. In the Network monitor settings, you specify the path you want to monitor. For information about setting up the Network monitor, see the *Astra LoadTest Controller User's Guide*. 
Network Delay Time Graph

The Network Delay Time graph shows the delays for the complete path between the source and destination machines (for example, the database server and Vuser load generator). The graph maps the delay as a function of the elapsed scenario time.

Each path defined in the Controller is represented by a separate line with a different color in the graph.

The following graph shows the network delay as a function of the elapsed scenario time. It shows a delay of 16 milliseconds in the 8th minute of the scenario.
Network Sub-Path Time Graph

The Network Sub-Path Time graph shows the delay for each segment of the path according to the elapsed scenario time. Each segment is displayed as a separate line with a different color.

In the following example, four segments are shown. The graph indicates that one segment caused a delay of 70 milliseconds in the sixth minute.

Note: The delays from the source machine to each of the nodes are measured concurrently, yet independently. It is therefore possible that the delay from the source machine to one of the nodes could be greater than the delay for the complete path between the source and destination machines.
Network Segment Delay Graph

The Network Segment Delay graph shows the delay for each segment of the path according to the elapsed scenario time. Each segment is displayed as a separate line with a different color.

In the following example, four segments are shown. The graph indicates that one segment caused a delay of 70 seconds in the sixth minute.

Note: The segment delays are measured approximately, and do not add up to the network path delay which is measured exactly. The delay for each segment of the path is estimated by calculating the delay from the source machine to one node and subtracting the delay from the source machine to another node. For example, the delay for segment B to C is calculated by measuring the delay from the source machine to point C, and subtracting the delay from the source machine to point B.
Verifying the Network as a Bottleneck

You can merge various graphs to determine if the network is a bottleneck. For example, using the Network Delay Time and Running Vusers graphs, you can determine how the number of Vusers affects the network delay. The Network Delay Time graph indicates the network delay during the scenario run. The Running Vusers graph shows the number of running Vusers.

In the following merged graph, the network delays are compared to the running Vusers. The graph shows that when all 10 Vusers were running, a network delay of 22 milliseconds occurred, implying that the network may be overloaded.
Firewall Server Monitor Graphs

After a scenario run, you can use the Firewall server monitor graphs to analyze Firewall server performance.

This chapter describes the:

➤ Check Point FireWall-1 Server Graph

About Firewall Server Monitor Graphs

Firewall server monitor graphs provide you with performance information for firewall servers. Note that in order to obtain data for these graphs, you need to activate the Firewall server online monitor before running the scenario. When you set up the online monitor for the Firewall server, you indicate which statistics and measurements to monitor. For more information on activating and configuring Firewall server monitors, see the Astra LoadTest Controller User’s Guide.
Check Point FireWall-1 Server Graph

The Check Point FireWall-1 graph shows statistics on Check Point’s Firewall server as a function of the elapsed scenario time.

This graph displays the \texttt{fwDropped}, \texttt{fwLogged}, and \texttt{fwRejected} measurements during the first minute and twenty seconds of the scenario. Note that there are differences in the scale factor for the measurements: the scale factor for \texttt{fwDropped} is 1, the scale factor for \texttt{fwLogged} is 10, and the scale factor for \texttt{fwRejected} is 0.0001.

The following measurements are available for the Check Point FireWall-1 server:

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>\texttt{fwRejected}</td>
<td>The number of rejected packets.</td>
</tr>
<tr>
<td>\texttt{fwDropped}</td>
<td>The number of dropped packets.</td>
</tr>
<tr>
<td>\texttt{fwLogged}</td>
<td>The number of logged packets.</td>
</tr>
</tbody>
</table>
After a scenario run, you can use Web Server Resource graphs to analyze the performance of your Apache, Microsoft IIS, and iPlanet/Netscape server performance.

This chapter describes:
- Apache Server Graph
- Microsoft Information Internet Server (IIS) Graph
- iPlanet/Netscape Server Graph

**About Web Server Resource Graphs**

Web Server Resource graphs provide you with information about the resource usage of the Apache, Microsoft IIS, and iPlanet/Netscape Web servers. In order to obtain data for these graphs, you need to activate the online monitor for the server and specify which resources you want to measure before running the scenario. For information on activating and configuring the Web Server Resource monitors, see the *Astra LoadTest Controller User’s Guide*.

In order to display all the measurements on a single graph, the Analysis may scale them. The Legend tab indicates the scale factor for each resource. To obtain the true value, multiply the scale factor by the displayed value. For example, in the following graph the actual value of *KBytes Sent per second* in
the second minute is 1; 10 multiplied by the scale factor of 1/10 (indicated in the Legend tab below).

Apache Server Graph

The Apache Server graph shows server statistics as a function of the elapsed scenario time.

In the above graph, the CPU usage remained steady throughout the scenario. At the end of the scenario, the number of idle servers increased. The number of busy servers remained steady at 1 throughout the scenario, implying that the Vuser only accessed one Apache server.
Note that the scale factor for the *Busy Servers* measurement is 1/10 and the scale factor for *CPU usage* is 10.

The following default measurements are available for the Apache server:

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td># Busy Servers</td>
<td>The number of servers in the Busy state</td>
</tr>
<tr>
<td># Idle Servers</td>
<td>The number of servers in the Idle state</td>
</tr>
<tr>
<td>Apache CPU Usage</td>
<td>The percentage of time the CPU is utilized by the Apache server</td>
</tr>
<tr>
<td>Hits/sec</td>
<td>The HTTP request rate</td>
</tr>
<tr>
<td>KBytes Sent/sec</td>
<td>The rate at which data bytes are sent from the Web server</td>
</tr>
</tbody>
</table>

**Note:** The Apache monitor connects to the Web server in order to gather statistics, and registers one hit for each sampling. The Apache graph, therefore, always displays one hit per second, even if no clients are connected to the Apache server.
Microsoft Information Internet Server (IIS) Graph

The Microsoft IIS Server graph shows server statistics as a function of the elapsed scenario time.

In the above graph, the Bytes Received/sec and Get Requests/sec measurements remained fairly steady throughout the scenario, while the % Total Processor Time, Bytes Sent/sec, and Post Requests/sec measurements fluctuated considerably.

Note that the scale factor for the Bytes Sent/sec and Bytes Received/sec measurements is 1/100, and the scale factor for the Post Requests/sec measurement is 10.
Chapter 11 • Web Server Resource Graphs

The following default measurements are available for the IIS server:

<table>
<thead>
<tr>
<th>Object</th>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Web Service</td>
<td>Bytes Sent/sec</td>
<td>The rate at which the data bytes are sent by the Web service</td>
</tr>
<tr>
<td>Web Service</td>
<td>Bytes Received/sec</td>
<td>The rate at which the data bytes are received by the Web service</td>
</tr>
<tr>
<td>Web Service</td>
<td>Get Requests/sec</td>
<td>The rate at which HTTP requests using the GET method are made. Get requests are generally used for basic file retrievals or image maps, though they can be used with forms.</td>
</tr>
<tr>
<td>Web Service</td>
<td>Post Requests/sec</td>
<td>The rate at which HTTP requests using the POST method are made. Post requests are generally used for forms or gateway requests.</td>
</tr>
<tr>
<td>Web Service</td>
<td>Maximum Connections</td>
<td>The maximum number of simultaneous connections established with the Web service</td>
</tr>
<tr>
<td>Web Service</td>
<td>Current Connections</td>
<td>The current number of connections established with the Web service</td>
</tr>
<tr>
<td>Web Service</td>
<td>Current NonAnonymous Users</td>
<td>The number of users that currently have a non-anonymous connection using the Web service</td>
</tr>
<tr>
<td>Web Service</td>
<td>Not Found Errors/sec</td>
<td>The rate of errors due to requests that could not be satisfied by the server because the requested document could not be found. These are generally reported to the client as an HTTP 404 error code.</td>
</tr>
<tr>
<td>Process</td>
<td>Private Bytes</td>
<td>The current number of bytes that the process has allocated that cannot be shared with other processes.</td>
</tr>
</tbody>
</table>
iPlanet/Netscape Server Graph

The iPlanet/Netscape Server graph shows server statistics as a function of the elapsed scenario time.

Note that the scale factor for the 302/sec and 3xx/sec measurements is 100, and the scale factor for the Bytes Sent/sec is 1/100.

The following default measurements are available for the iPlanet/Netscape server:

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>200/sec</td>
<td>The rate of successful transactions being processed by the server</td>
</tr>
<tr>
<td>2xx/sec</td>
<td>The rate at which the server handles status codes in the 200 to 299 range</td>
</tr>
<tr>
<td>302/sec</td>
<td>The rate of relocated URLs being processed by the server</td>
</tr>
<tr>
<td>304/sec</td>
<td>The rate of requests for which the server tells the user to use a local copy of a URL instead of retrieving a newer version from the server</td>
</tr>
<tr>
<td>Measurement</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>-------------</td>
</tr>
<tr>
<td>3xx/sec</td>
<td>The rate at which the server handles status codes in the 300 to 399 range</td>
</tr>
<tr>
<td>401/sec</td>
<td>The rate of unauthorized requests handled by the server</td>
</tr>
<tr>
<td>403/sec</td>
<td>The rate of forbidden URL status codes handled by the server</td>
</tr>
<tr>
<td>4xx/sec</td>
<td>The rate at which the server handles status codes in the 400 to 499 range</td>
</tr>
<tr>
<td>5xx/sec</td>
<td>The rate at which the server handles status codes 500 and higher</td>
</tr>
<tr>
<td>Bad requests/sec</td>
<td>The rate at which the server handles bad requests</td>
</tr>
<tr>
<td>Bytes sent/sec</td>
<td>The rate at which bytes of data are sent from the Web server</td>
</tr>
<tr>
<td>Hits/sec</td>
<td>The HTTP request rate</td>
</tr>
<tr>
<td>xxx/sec</td>
<td>The rate of all status codes (2xx-5xx) handled by the server, excluding timeouts and other errors that did return an HTTP status code</td>
</tr>
</tbody>
</table>
After a scenario run, you can use Web Application Server Resource graphs to analyze Web application server performance.

This chapter describes:

➤ Ariba Graph
➤ ATG Dynamo Graph
➤ BroadVision Graph
➤ Brokat Twister Graph
➤ ColdFusion Graph
➤ Fujitsu INTERSTAGE Graph
➤ Microsoft Active Server Pages (ASP) Graph
➤ Oracle9iAS HTTP Server Graph
➤ SilverStream Graph
➤ WebLogic (SNMP) Graph
➤ WebLogic (JMX) Graph
➤ WebSphere Graph
About Web Application Server Resource Graphs

Web Application Server Resource graphs provide you with resource usage information about the Ariba, ATG Dynamo, BroadVision, Brokat Twister, ColdFusion, Fujitsu INTERSTAGE, Microsoft ASP, Oracle9iAS HTTP, SilverStream, WebLogic (SNMP), WebLogic (JMX), and WebSphere application servers.

In order to obtain data for these graphs, you need to activate the online monitor for the application server and specify which resources you want to measure before running the scenario. For information on activating and configuring the Web Application Server Resource monitors, see the Astra LoadTest Controller User's Guide.

When you open a Web Application Server Resource graph, you can filter it to show only the relevant application. When you need to analyze other applications, you can change the filter conditions and display the desired resources.

In order to display all the measurements on a single graph, the Analysis may scale them. The Legend tab indicates the scale factor for each resource. To obtain the true value, multiply the scale factor by the displayed value. For more information on scaled measurements, see the example in “About Web Server Resource Graphs” on page 113.
Ariba Graph

The following tables describe the default measurements available for the Ariba server:

**Core Server Performance Counters**

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total Connections</td>
<td>The cumulative number of concurrent user connections since Ariba Buyer was started.</td>
</tr>
<tr>
<td>Requisitions Finished</td>
<td>The instantaneous reading of the length of the worker queue at the moment this metric is obtained. The longer the worker queue, the more user requests are delayed for processing.</td>
</tr>
<tr>
<td>Worker Queue Length</td>
<td>The instantaneous reading of the length of the worker queue at the moment this metric is obtained. The longer the worker queue, the more user requests are delayed for processing.</td>
</tr>
<tr>
<td>Concurrent Connections</td>
<td>The instantaneous reading of the number of concurrent user connections at the moment this metric is obtained.</td>
</tr>
<tr>
<td>Total Memory</td>
<td>The instantaneous reading of the memory (in KB) being used by Ariba Buyer at the moment this metric is obtained.</td>
</tr>
<tr>
<td>Free Memory</td>
<td>The instantaneous reading of the reserved memory (in KB) that is not currently in use at the moment this metric is obtained.</td>
</tr>
<tr>
<td>Up Time</td>
<td>The amount of time (in hours and minutes) that Ariba Buyer has been running since the previous time it was started.</td>
</tr>
<tr>
<td>Number of Threads</td>
<td>The instantaneous reading of the number of server threads in existence at the moment this metric is obtained.</td>
</tr>
<tr>
<td>Number of Cached Objects</td>
<td>The instantaneous reading of the number of Ariba Buyer objects being held in memory at the moment this metric is obtained.</td>
</tr>
</tbody>
</table>
### System Related Performance Counters

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Average Session Length</td>
<td>The average length of the user sessions (in seconds) of all users who logged out since previous sampling time. This value indicates on average how long a user stays connected to server.</td>
</tr>
<tr>
<td>Average Idle Time</td>
<td>The average idle time (in seconds) for all the users who are active since previous sampling time. The idle time is the period of time between two consecutive user requests from the same user.</td>
</tr>
<tr>
<td>Approves</td>
<td>The cumulative count of the number of approves that happened during the sampling period. An Approve consists of a user approving one Approvable.</td>
</tr>
<tr>
<td>Submits</td>
<td>The cumulative count of the number of Approvables submitted since previous sampling time</td>
</tr>
<tr>
<td>Denies</td>
<td>The cumulative count of the number of submitted Approvables denied since previous sampling time</td>
</tr>
<tr>
<td>Object Cache Accesses</td>
<td>The cumulative count of accesses (both reads and writes) to the object cache since previous sampling time</td>
</tr>
<tr>
<td>Object Cache Hits</td>
<td>The cumulative count of accesses to the object cache that are successful (cache hits) since previous sampling time</td>
</tr>
<tr>
<td>Database Response Time</td>
<td>The average response time (in seconds) to the database requests since the previous sampling time</td>
</tr>
<tr>
<td>Buyer to DB server Traffic</td>
<td>The cumulative number of bytes that Ariba Buyer sent to DB server since the previous sampling time.</td>
</tr>
<tr>
<td>DB to Buyer server Traffic</td>
<td>The cumulative number of bytes that DB server sent to Ariba Buyer since the previous sampling time.</td>
</tr>
</tbody>
</table>
Chapter 12 • Web Application Server Resource Graphs

ATG Dynamo Graph

The following tables describe the measurements that are available for the ATG Dynamo server:

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Database Query Packets</td>
<td>The average number of packets that Ariba Buyer sent to DB server since the previous sampling time</td>
</tr>
<tr>
<td>Database Response Packets</td>
<td>The average number of packets that DB server sent to Ariba Buyer since the previous sampling time</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>d3System Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>sysTotalMem</td>
<td>The total amount of memory currently available for allocating objects, measured in bytes</td>
</tr>
<tr>
<td>sysFreeMem</td>
<td>An approximation of the total amount of memory currently available for future allocated objects, measured in bytes</td>
</tr>
<tr>
<td>sysNumInfoMsgs</td>
<td>The number of system global info messages written</td>
</tr>
<tr>
<td>sysNumWarningMsgs</td>
<td>The number of system global warning messages written</td>
</tr>
<tr>
<td>sysNumErrorMsgs</td>
<td>The number of system global error messages written</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>d3LoadManagement Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>lmIsManager</td>
<td>True if the Dynamo is running a load manager</td>
</tr>
<tr>
<td>lmManagerIndex</td>
<td>Returns the Dynamo’s offset into the list of load managing entities</td>
</tr>
<tr>
<td>lmIsPrimaryManager</td>
<td>True if the load manager is an acting primary manager</td>
</tr>
</tbody>
</table>
### Astra LoadTest Analysis User's Guide

**d3LoadManagement Measurement**  |  Description
--- | ---
ImServicingCMs | True if the load manager has serviced any connection module requests in the amount of time set as the connection module polling interval
ImCMLDRPPort | The port of the connection module agent
ImIndex | A unique value for each managed entity
ImSNMPPort | The port for the entry’s SNMP agent
ImProbability | The probability that the entry will be given a new session
ImNewSessions | Indicates whether or not the entry is accepting new sessions, or if the load manager is allowing new sessions to be sent to the entry. This value is inclusive of any override indicated by ImNewSessionOverride.
ImNewSessionOverride | The override set for whether or not a server is accepting new sessions

**d3SessionTracking Measurement**  |  Description
--- | ---
stCreatedSessionCnt | The number of created sessions
stValidSessionCnt | The number of valid sessions
stRestoredSessionCnt | The number of sessions migrated to the server
StDictionaryServerStatus | d3Session Tracking

**d3DRPServer Measurement**  |  Description
--- | ---
drpPort | The port of the DRP server
drpTotalReqsServed | Total number of DRP requests serviced
### Chapter 12 • Web Application Server Resource Graphs

<table>
<thead>
<tr>
<th><strong>d3DRPServer</strong> Measurement</th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>drpTotalReqTime</td>
<td>Total service time in msecs for all DRP requests</td>
</tr>
<tr>
<td>drpAvgReqTime</td>
<td>Average service time in msecs for each DRP request</td>
</tr>
<tr>
<td>drpNewessions</td>
<td>True if the Dynamo is accepting new sessions</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>d3DBConnPooling</strong> Measurement</th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>dbPoolsEntry</td>
<td>A pooling service entry containing information about the pool configuration and current status</td>
</tr>
<tr>
<td>dbIndex</td>
<td>A unique value for each pooling service</td>
</tr>
<tr>
<td>dbPoolID</td>
<td>The name of the DB connection pool service</td>
</tr>
<tr>
<td>dbMinConn</td>
<td>The minimum number of connections pooled</td>
</tr>
<tr>
<td>dbMaxConn</td>
<td>The maximum number of connections pooled</td>
</tr>
<tr>
<td>dbMaxFreeConn</td>
<td>The maximum number of free pooled connections at a time</td>
</tr>
<tr>
<td>dbBlocking</td>
<td>Indicates whether or not the pool is to block out check outs</td>
</tr>
<tr>
<td>dbConnOut</td>
<td>Returns the number of connections checked out</td>
</tr>
<tr>
<td>dbFreeResources</td>
<td>Returns the number of free connections in the pool. This number refers to connections actually created that are not currently checked out. It does not include how many more connections are allowed to be created as set by the maximum number of connections allowed in the pool.</td>
</tr>
<tr>
<td>dbTotalResources</td>
<td>Returns the number of total connections in the pool. This number refers to connections actually created and is not an indication of how many more connections may be created and used in the pool.</td>
</tr>
</tbody>
</table>
**BroadVision Graph**

The BroadVision monitor supplies performance statistics for all the servers/services available within the application server.

The following table describes all the servers/services that are available:

<table>
<thead>
<tr>
<th>Server</th>
<th>Multiple Instances</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>adm_srv</td>
<td>No</td>
<td>One-To-One user administration server. There must be one.</td>
</tr>
<tr>
<td>alert_srv</td>
<td>No</td>
<td>Alert server handles direct IDL function calls to the Alert system.</td>
</tr>
<tr>
<td>bvconf_srv</td>
<td>No</td>
<td>One-To-One configuration management server. There must be one.</td>
</tr>
<tr>
<td>cmsdb</td>
<td>Yes</td>
<td>Visitor management database server.</td>
</tr>
<tr>
<td>cntdb</td>
<td>Yes</td>
<td>Content database server.</td>
</tr>
<tr>
<td>deliv_smtp_d</td>
<td>Yes</td>
<td>Notification delivery server for e-mail type messages. Each instance of this server must have its own ID, numbered sequentially starting with &quot;1&quot;.</td>
</tr>
<tr>
<td>deliv_comp_d</td>
<td>No</td>
<td>Notification delivery completion processor.</td>
</tr>
<tr>
<td>extdbacc</td>
<td>Yes</td>
<td>External database accessor. You need at least one for each external data source.</td>
</tr>
<tr>
<td>genericdb</td>
<td>No</td>
<td>Generic database accessor handles content query requests from applications, when specifically called from the application. This is also used by the One-To-One Command Center.</td>
</tr>
<tr>
<td>hostmgr</td>
<td>Yes</td>
<td>Defines a host manager process for each machine that participates in One-To-One, but doesn’t run any One-To-One servers. For example, you need a hostmgr on a machine that runs only servers. You don’t need a separate hostmgr on a machine that already has one of the servers in this list.</td>
</tr>
<tr>
<td>g1_ofbe_srv</td>
<td>No</td>
<td>Order fulfillment back-end server.</td>
</tr>
</tbody>
</table>
### Performance Counters

Performance counters for each server/service are divided into logical groups according to the service type.

The following section describes all the available counters under each group. Please note that for some services the number of counters for the same group can be different.

<table>
<thead>
<tr>
<th>Server</th>
<th>Multiple Instances</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>g1_ofdb</td>
<td>Yes</td>
<td>Order fulfillment database server.</td>
</tr>
<tr>
<td>g1_om_srv</td>
<td>No</td>
<td>Order management server.</td>
</tr>
<tr>
<td>pmtassign_d</td>
<td>No</td>
<td>The payment archiving daemon routes payment records to the archives by periodically checking the invoices table, looking for records with completed payment transactions, and then moving those records into an archive table.</td>
</tr>
<tr>
<td>pmthdlr_d</td>
<td>Yes</td>
<td>For each payment processing method, you need one or more authorization daemons to periodically acquire the authorization when a request is made.</td>
</tr>
<tr>
<td>pmtsettle_d</td>
<td>Yes</td>
<td>Payment settlement daemon periodically checks the database for orders of the associated payment processing method that need to be settled, and then authorizes the transactions.</td>
</tr>
<tr>
<td>sched_poll_d</td>
<td>No</td>
<td>Notification schedule poller scans the database tables to determine when a notification must be run.</td>
</tr>
<tr>
<td>sched_srv</td>
<td>Yes</td>
<td>Notification schedule server runs the scripts that generate the visitor notification messages.</td>
</tr>
</tbody>
</table>
Counter groups:

➤ BV_DB_STAT
➤ BV_SRV_CTRL
➤ BV_SRV_STAT
➤ NS_STAT
➤ BV_CACHE_STAT
➤ JS_SCRIPT_CTRL
➤ JS_SCRIPT_STAT

**BV_DB_STAT**

The database accessor processes have additional statistics available from the BV_DB_STAT memory block. These statistics provide information about database accesses, including the count of selects, updates, inserts, deletes, and stored procedure executions.

➤ DELETE - Count of deletes executions
➤ INSERT - Count of inserts executions
➤ SELECT - Count of selects executions
➤ SPROC - Count of stored procedure executions.
➤ UPDATE - Count of updates executions

**BV_SRV_CTRL**

➤ SHUTDOWN
NS_STAT

The NS process displays the namespace for the current One-To-One environment, and optionally can update objects in a name space.

➤ Bind
➤ List
➤ New
➤ Rebnd
➤ Rsolv
➤ Unbnd

BV_SRV_STAT

The display for Interaction Manager processes includes information about the current count of sessions, connections, idle sessions, threads in use, and count of CGI requests processed.

➤ HOST - Host machine running the process.
➤ ID - Instance of the process (of which multiple can be configured in the bv1to1.conf file), or engine ID of the Interaction Manager.
➤ CGI - Current count of CGI requests processed.
➤ CONN - Current count of connections.
➤ CPU - CPU percentage consumed by this process. If a process is using most of the CPU time, consider moving it to another host, or creating an additional process, possibly running on another machine. Both of these specifications are done in the bv1to1.conf file. The CPU % reported is against a single processor. If a server is taking up a whole CPU on a 4 processor machine, this statistic will report 100%, while the Windows NT Task Manager will report 25%. The value reported by this statistic is consistent with "% Processor Time" on the Windows NT Performance Monitor.
➤ GROUP - Process group (which is defined in the bv1to1.conf file), or Interaction Manager application name.
➤ **STIME** - Start time of server. The start times should be relatively close. Later times might be an indication that a server crashed and was automatically restarted.

➤ **IDL** - Total count of IDL requests received, not including those to the monitor.

➤ **IdIQ**

➤ **JOB**

➤ **LWP** - Number of light-weight processes (threads).

➤ **RSS** - Resident memory size of server process (in Kilobytes).

➤ **STIME** - System start time.

➤ **SESS** - Current count of sessions.

➤ **SYS** - Accumulated system mode CPU time (seconds).

➤ **THR** - Current count of threads.

➤ **USR** - Accumulated user mode CPU time (seconds).

➤ **VSZ** - Virtual memory size of server process (in kilobytes). If a process is growing in size, it probably has a memory leak. If it is an Interaction Manager process, the culprit is most likely a component or dynamic object (though Interaction Manager servers do grow and shrink from garbage collection during normal use).

**BV_CACHE_STAT**

Monitors the request cache status.

The available counters for each request are:

➤ **CNT- Request_Name-HIT** - Count of requests found in the cache.

➤ **CNT- Request_Name-MAX** - Maximum size of the cache in bytes

➤ **CNT- Request_Name-SWAP** - Count of items that got swapped out of the cache.

➤ **CNT- Request_Name-MISS** - Count of requests that were not in the cache.

➤ **CNT- Request_Name-SIZE** - Count of items currently in the cache.
Cache Metrics

Cache metrics are available for the following items:

➤ AD

➤ ALERTSCHED - Notification schedules are defined in the BV_ALERTSCHED and BV_MSGSCHED tables. They are defined by the One-To-One Command Center user or by an application.

➤ CATEGORY_CONTENT

➤ DISCUSSION - The One-To-One discussion groups provide moderated system of messages and threads of messages aligned to a particular topic. Use the Discussion group interfaces for creating, retrieving and deleting individual messages in a discussion group. To create, delete, or retrieve discussion groups, use the generic content management API. The BV_DiscussionDB object provides access to the threads and messages in the discussion group database.

➤ EXT_FIN_PRODUCT

➤ EDITORIAL - Using the Editorials content module, you can point cast and community cast personalized editorial content, and sell published text on your One-To-One site. You can solicit editorial content, such as investment reports and weekly columns, from outside authors and publishers, and create your own articles, reviews, reports, and other informative media. In addition to text, you can use images, sounds, music, and video presentations as editorial content.

➤ INCENTIVE - Contains sales incentives

➤ MSGSCHED - Contains the specifications of visitor-message jobs. Notification schedules are defined in the BV_ALERTSCHED and BV_MSGSCHED tables. They are defined by the One-To-One Command Center user or by an application.

➤ MSGSCRIPT - Contains the descriptions of the JavaScripts that generate visitor messages and alert messages. Contains the descriptions of the JavaScripts that generate targeted messages and alert messages. Use the Command Center to add message script information to this table by selecting the Visitor Messages module in the Notifications group. For more information, see the Command Center User's Guide.
➤ PRODUCT - BV_PRODUCT contains information about the products that a visitor can purchase.

➤ QUERY - BV_QUERY contains queries.

➤ SCRIPT - BV_SCRIPT contains page scripts.

➤ SECURITIES

➤ TEMPLATE - The Templates content module enables you to store in the content database any BroadVision page templates used on your One-To-One site. Combining BroadVision page templates with BroadVision dynamic objects in the One-To-One Design Center application is one way for site developers to create One-To-One Web sites. If your developers use these page templates, you can use the Command Center to enter and manage them in your content database. If your site doesn’t use BroadVision page template, you will not use this content module.

JS_SCRIPT_CTRL

➤ CACHE
➤ DUMP
➤ FLUSH
➤ METER
➤ TRACE

JS_SCRIPT_STAT

➤ ALLOC
➤ ERROR
➤ FAIL
➤ JSPERR
➤ RELEASE
➤ STOP
➤ SUCC
➤ SYNTAX
**Brokat Twister Graph**

The following default measurements are available for the Brokat Twister server:

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>nam-boundObjTable</td>
<td>A table that contains information about the Naming Service's bound objects</td>
</tr>
<tr>
<td>nam-boundObjEntry</td>
<td>A row in the nam-boundObjTable table</td>
</tr>
<tr>
<td>nam-boundObjId</td>
<td>The ID is the unique logical name by which the object is known in the Brokat Twister environment.</td>
</tr>
<tr>
<td>nam-boundObjAvail</td>
<td>The object may be available (true) or unavailable (false). One possible reason for an object not being available is that the service is not running.</td>
</tr>
<tr>
<td>nam-boundObjHost</td>
<td>The machine on which this object is running</td>
</tr>
<tr>
<td>nam-boundObjPort</td>
<td>The port where this object can be accessed</td>
</tr>
<tr>
<td>nam-boundObjKey</td>
<td>ObjectKey is the server object name</td>
</tr>
<tr>
<td>nam-boundObjTypeId</td>
<td>Typeid is the object type as defined by Corba</td>
</tr>
<tr>
<td>rep-status</td>
<td>The status of the repository service</td>
</tr>
<tr>
<td>rep-ipAddress</td>
<td>The IP address of the repository service</td>
</tr>
<tr>
<td>rep-iiopPort</td>
<td>The IIOP port of the repository service</td>
</tr>
<tr>
<td>lic-status</td>
<td>The status of the license service</td>
</tr>
<tr>
<td>lic-ipAddress</td>
<td>The IP address of the license service</td>
</tr>
<tr>
<td>lic-iiopPort</td>
<td>The IIOP port of the license service</td>
</tr>
<tr>
<td>lic-flatLicenseTable</td>
<td>A table of flat licenses</td>
</tr>
<tr>
<td>lic-flatLicenseEntry</td>
<td>An entry in the flat licenses table</td>
</tr>
<tr>
<td>lic-flatLicenseName</td>
<td>The name of a flat license</td>
</tr>
<tr>
<td>lic-cpuBasedLicenseTable</td>
<td>A table of CPU-based licenses</td>
</tr>
<tr>
<td>lic-cpuBasedLicenseEntry</td>
<td>An entry in the CPU-based licenses table</td>
</tr>
<tr>
<td>Measurement</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>lic-cpuBasedLicenseName</td>
<td>The name of a CPU-based license</td>
</tr>
<tr>
<td>lic-cpuBasedLicenseInUse</td>
<td>The usage of a CPU-based license</td>
</tr>
<tr>
<td>lic-PlatformTable</td>
<td>A table of platform entries</td>
</tr>
<tr>
<td>lic-PlatformEntry</td>
<td>An entry in the platform table</td>
</tr>
<tr>
<td>lic-platformName</td>
<td>The name of a platform</td>
</tr>
<tr>
<td>lic-platformRole</td>
<td>A server or client platform</td>
</tr>
<tr>
<td>lic-platformCPUmax</td>
<td>The maximum number of CPUs for a platform</td>
</tr>
<tr>
<td>lic-platformCPUinUse</td>
<td>The number of CPUs currently in use for a platform</td>
</tr>
<tr>
<td>lb-status</td>
<td>The status of the load balancing service</td>
</tr>
<tr>
<td>lb-ipAddress</td>
<td>The IP address of the load balancing service</td>
</tr>
<tr>
<td>lb-iiopPort</td>
<td>The IIOP port of the load balancing service</td>
</tr>
<tr>
<td>lb-objUsed</td>
<td>The number of object managers currently running</td>
</tr>
<tr>
<td>lb-objMax</td>
<td>The maximum number of object managers available</td>
</tr>
<tr>
<td>lb-objPeak</td>
<td>The maximum number of object managers used</td>
</tr>
<tr>
<td>lb-objMgrTable</td>
<td>A table of all object managers</td>
</tr>
<tr>
<td>lb-objMgrEntry</td>
<td>An entry in the object managers table</td>
</tr>
<tr>
<td>lb-objMgrLoad</td>
<td>The current load of object managers (in %)</td>
</tr>
<tr>
<td>lb-objMgrPort</td>
<td>The IIOP port number of the object manager</td>
</tr>
<tr>
<td>lb-objMgrStatus</td>
<td>The status of the object managers</td>
</tr>
<tr>
<td>lb-ejbUsed</td>
<td>The number of EJB managers currently running</td>
</tr>
<tr>
<td>lb-ejbMax</td>
<td>The maximum number of EJB managers available</td>
</tr>
<tr>
<td>lb-ejbPeak</td>
<td>The maximum number of EJB managers used</td>
</tr>
<tr>
<td>lb-ejbMgrTable</td>
<td>A table of all EJB managers</td>
</tr>
<tr>
<td>lb-ejbMgrEntry</td>
<td>An entry in the EJB managers table</td>
</tr>
</tbody>
</table>
### Chapter 12 • Web Application Server Resource Graphs

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>lb-ejbMgrLoad</td>
<td>The current load of EJB managers (in %)</td>
</tr>
<tr>
<td>lb-ejbMgrPort</td>
<td>The IIOP port number of the EJB manager</td>
</tr>
<tr>
<td>lb-ejbMgrStatus</td>
<td>The status of EJB managers</td>
</tr>
<tr>
<td>lb-sloUsed</td>
<td>The number of stateless object managers currently running</td>
</tr>
<tr>
<td>lb-sloMax</td>
<td>The maximum number of stateless object managers available</td>
</tr>
<tr>
<td>lb-sloPeak</td>
<td>The maximum number of stateless object managers used</td>
</tr>
<tr>
<td>lb-sloMgrTable</td>
<td>A table of all stateless object managers</td>
</tr>
<tr>
<td>lb-sloMgrEntry</td>
<td>An entry in the stateless object managers table</td>
</tr>
<tr>
<td>lb-sloMgrLoad</td>
<td>The current load of stateless object managers (in %)</td>
</tr>
<tr>
<td>lb-sloMgrPort</td>
<td>The IIOP port number of the stateless object manager</td>
</tr>
<tr>
<td>lb-sloMgrStatus</td>
<td>The status of stateless object managers</td>
</tr>
<tr>
<td>trans-status</td>
<td>The status of the transaction service</td>
</tr>
<tr>
<td>trans-ipAddress</td>
<td>The IP address of the transaction service</td>
</tr>
<tr>
<td>trans-iiopPort</td>
<td>The IIOP port of the transaction service</td>
</tr>
<tr>
<td>trans-detOpen</td>
<td>The number of open transactions</td>
</tr>
<tr>
<td>trans-detExec</td>
<td>The number of transactions executed</td>
</tr>
<tr>
<td>trans-detCommit</td>
<td>The number of transactions committed</td>
</tr>
<tr>
<td>trans-detRollback</td>
<td>The number of transactions rolled back</td>
</tr>
<tr>
<td>trans-detFailed</td>
<td>The number of transactions failed</td>
</tr>
<tr>
<td>trans-detTimeout</td>
<td>The number of transactions timed out</td>
</tr>
<tr>
<td>mgrtr-status</td>
<td>The status of the transaction manager</td>
</tr>
<tr>
<td>mgrtr-ipAddress</td>
<td>The IP address of the transaction manager</td>
</tr>
<tr>
<td>Measurement</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>-------------------------------------------------------</td>
</tr>
<tr>
<td>mgrtr-iiopPort</td>
<td>The IIOP port of the transaction manager</td>
</tr>
<tr>
<td>snmp-status</td>
<td>The status of the snmp service</td>
</tr>
<tr>
<td>snmp-ipAddress</td>
<td>The IP address of the snmp service</td>
</tr>
<tr>
<td>snmp-iiopPort</td>
<td>The IIOP port of the snmp service</td>
</tr>
<tr>
<td>evt-status</td>
<td>The status of the event service</td>
</tr>
<tr>
<td>evt-ipAddress</td>
<td>The IP address of the event service</td>
</tr>
<tr>
<td>evt-iiopPort</td>
<td>The IIOP port of the event service</td>
</tr>
<tr>
<td>evt-detChannels</td>
<td>The number of channels registered to the event service</td>
</tr>
<tr>
<td>evt-detSuppliers</td>
<td>The number of event suppliers registered to the event service</td>
</tr>
<tr>
<td>evt-detConsumers</td>
<td>The number of event consumers registered to the event service</td>
</tr>
<tr>
<td>so-status</td>
<td>The status of the sharedObject service</td>
</tr>
<tr>
<td>so-ipAddress</td>
<td>The IP address of the sharedObject service</td>
</tr>
<tr>
<td>so-iiopPort</td>
<td>The IIOP port of the sharedObject service</td>
</tr>
<tr>
<td>so-sharedPools</td>
<td>The number of shared pools</td>
</tr>
<tr>
<td>so-sharedRDOs</td>
<td>The number of shared RDOs</td>
</tr>
</tbody>
</table>
ColdFusion Graph

The following default measurements are available for Allaire’s ColdFusion server:

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Avg. Queue Time (msec)</td>
<td>The running average of the amount of time, in milliseconds, that requests spent waiting in the ColdFusion input queue before ColdFusion began to process the request.</td>
</tr>
<tr>
<td>Avg Req Time (msec)</td>
<td>The running average of the total amount of time, in milliseconds, that it takes ColdFusion to process a request. In addition to general page processing time, this value includes both queue time and database processing time.</td>
</tr>
<tr>
<td>Bytes Out/sec</td>
<td>The number of bytes per second returned by the ColdFusion server.</td>
</tr>
<tr>
<td>Page Hits/sec</td>
<td>This is the number of Web pages processed per second by the ColdFusion server.</td>
</tr>
<tr>
<td>Queued Requests</td>
<td>The number of requests currently waiting to be processed by the ColdFusion server.</td>
</tr>
<tr>
<td>Running Requests</td>
<td>The number of requests currently being actively processed by the ColdFusion server.</td>
</tr>
</tbody>
</table>
Fujitsu INTERSTAGE Graph

The following default measurements are available for the Fujitsu INTERSTAGE server:

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>IspSumObjectName</td>
<td>The object name of the application for which performance information is measured</td>
</tr>
<tr>
<td>IspSumExecTimeMax</td>
<td>The maximum processing time of the application within a certain period of time</td>
</tr>
<tr>
<td>IspSumExecTimeMin</td>
<td>The minimum processing time of the application within a certain period of time</td>
</tr>
<tr>
<td>IspSumExecTimeAve</td>
<td>The average processing time of the application within a certain period of time</td>
</tr>
<tr>
<td>IspSumWaitTimeMax</td>
<td>The maximum time required for INTERSTAGE to start an application after a start request is issued</td>
</tr>
<tr>
<td>IspSumWaitTimeMin</td>
<td>The minimum time required for INTERSTAGE to start an application after a start request is issued</td>
</tr>
<tr>
<td>IspSumWaitTimeAve</td>
<td>The average time required for INTERSTAGE to start an application after a start request is issued</td>
</tr>
<tr>
<td>IspSumRequestNum</td>
<td>The number of requests to start an application</td>
</tr>
<tr>
<td>IspSumWaitReqNum</td>
<td>The number of requests awaiting application activation</td>
</tr>
</tbody>
</table>
## Microsoft Active Server Pages (ASP) Graph

The following default measurements are available for Microsoft Active Server Pages (ASP):

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Errors per Second</td>
<td>The number of errors per second.</td>
</tr>
<tr>
<td>Requests Wait Time</td>
<td>The number of milliseconds the most recent request was waiting in the queue.</td>
</tr>
<tr>
<td>Requests Executing</td>
<td>The number of requests currently executing.</td>
</tr>
<tr>
<td>Requests Queued</td>
<td>The number of requests waiting in the queue for service.</td>
</tr>
<tr>
<td>Requests Rejected</td>
<td>The total number of requests not executed because there were insufficient resources to process them.</td>
</tr>
<tr>
<td>Requests Not Found</td>
<td>The number of requests for files that were not found.</td>
</tr>
<tr>
<td>Requests/sec</td>
<td>The number of requests executed per second.</td>
</tr>
<tr>
<td>Memory Allocated</td>
<td>The total amount of memory, in bytes, currently allocated by Active Server Pages.</td>
</tr>
<tr>
<td>Errors During Script Run-Time</td>
<td>The number of failed requests due to run-time errors.</td>
</tr>
<tr>
<td>Sessions Current</td>
<td>The current number of sessions being serviced.</td>
</tr>
<tr>
<td>Transactions/sec</td>
<td>The number of transactions started per second.</td>
</tr>
</tbody>
</table>
## Oracle9iAS HTTP Server Graph

The following table describes some of the modules that are available for the Oracle9iAS HTTP server:

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>mod_mime.c</td>
<td>Determines document types using file extensions</td>
</tr>
<tr>
<td>mod_mime_magic.c</td>
<td>Determines document types using &quot;magic numbers&quot;</td>
</tr>
<tr>
<td>mod_auth_anon.c</td>
<td>Provides anonymous user access to authenticated areas</td>
</tr>
<tr>
<td>mod_auth_dbm.c</td>
<td>Provides user authentication using DBM files</td>
</tr>
<tr>
<td>mod_auth_digest.c</td>
<td>Provides MD5 authentication</td>
</tr>
<tr>
<td>mod_cern_meta.c</td>
<td>Supports HTTP header metafiles</td>
</tr>
<tr>
<td>mod_digest.c</td>
<td>Provides MD5 authentication (deprecated by mod_auth_digest)</td>
</tr>
<tr>
<td>mod_expires.c</td>
<td>Applies Expires: headers to resources</td>
</tr>
<tr>
<td>mod_headers.c</td>
<td>Adds arbitrary HTTP headers to resources</td>
</tr>
<tr>
<td>mod_proxy.c</td>
<td>Provides caching proxy abilities</td>
</tr>
<tr>
<td>mod_rewrite.c</td>
<td>Provides powerful URI-to-filename mapping using regular expressions</td>
</tr>
<tr>
<td>mod_speling.c</td>
<td>Automatically corrects minor typos in URLs</td>
</tr>
<tr>
<td>mod_info.c</td>
<td>Provides server configuration information</td>
</tr>
<tr>
<td>mod_status.c</td>
<td>Displays server status</td>
</tr>
<tr>
<td>mod_usertrack.c</td>
<td>Provides user tracking using cookies</td>
</tr>
<tr>
<td>mod_dms.c</td>
<td>Provides access to DMS Apache statistics</td>
</tr>
<tr>
<td>mod_perl.c</td>
<td>Allows execution of perl scripts</td>
</tr>
<tr>
<td>mod_fastcgi.c</td>
<td>Supports CGI access to long-lived programs</td>
</tr>
<tr>
<td>mod_ssl.c</td>
<td>Provides SSL support</td>
</tr>
<tr>
<td>mod_plsql.c</td>
<td>Handles requests for Oracle stored procedures</td>
</tr>
<tr>
<td>mod_isapi.c</td>
<td>Provides Windows ISAPI extension support</td>
</tr>
</tbody>
</table>
### Chapter 12 • Web Application Server Resource Graphs

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>mod_setenvif.c</code></td>
<td>Sets environment variables based on client information</td>
</tr>
<tr>
<td><code>mod_actions.c</code></td>
<td>Executes CGI scripts based on media type or request method</td>
</tr>
<tr>
<td><code>mod_imap.c</code></td>
<td>Handles imagemap files</td>
</tr>
<tr>
<td><code>mod_asis.c</code></td>
<td>Sends files that contain their own HTTP headers</td>
</tr>
<tr>
<td><code>mod_log_config.c</code></td>
<td>Provides user-configurable logging replacement for <code>mod_log_common</code></td>
</tr>
<tr>
<td><code>mod_env.c</code></td>
<td>Passes environments to CGI scripts</td>
</tr>
<tr>
<td><code>mod_alias.c</code></td>
<td>Maps different parts of the host file system in the document tree, and redirects URLs</td>
</tr>
<tr>
<td><code>mod_userdir.c</code></td>
<td>Handles user home directories</td>
</tr>
<tr>
<td><code>mod_cgi.c</code></td>
<td>Invokes CGI scripts</td>
</tr>
<tr>
<td><code>mod_dir.c</code></td>
<td>Handles the basic directory</td>
</tr>
<tr>
<td><code>mod_autoindex.c</code></td>
<td>Provides automatic directory listings</td>
</tr>
<tr>
<td><code>mod_include.c</code></td>
<td>Provides server-parsed documents</td>
</tr>
<tr>
<td><code>mod_negotiation.c</code></td>
<td>Handles content negotiation</td>
</tr>
<tr>
<td><code>mod_auth.c</code></td>
<td>Provides user authentication using text files</td>
</tr>
<tr>
<td><code>mod_access.c</code></td>
<td>Provides access control based on the client hostname or IP address</td>
</tr>
<tr>
<td><code>mod_so.c</code></td>
<td>Supports loading modules (.so on UNIX, .dll on Win32) at run-time</td>
</tr>
<tr>
<td><code>mod_oprocmgr.c</code></td>
<td>Monitors JServ processes and restarts them if they fail</td>
</tr>
<tr>
<td><code>mod_jserv.c</code></td>
<td>Routes HTTP requests to JServ server processes. Balances load across multiple JServs by distributing new requests in round-robin order</td>
</tr>
</tbody>
</table>
The following table describes the counters that are available for the Oracle9iAS HTTP server:

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>mod_ose.c</td>
<td>Routes requests to the JVM embedded in Oracle's database server</td>
</tr>
<tr>
<td>http_core.c</td>
<td>Handles requests for static Web pages</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle.minTime</td>
<td>The minimum time spent in the module handler</td>
</tr>
<tr>
<td>handle.avg</td>
<td>The average time spent in the module handler</td>
</tr>
<tr>
<td>handle.active</td>
<td>The number of threads currently in the handle processing phase</td>
</tr>
<tr>
<td>handle.time</td>
<td>The total amount of time spent in the module handler</td>
</tr>
<tr>
<td>handle.completed</td>
<td>The number of times the handle processing phase was completed</td>
</tr>
<tr>
<td>request.maxTime</td>
<td>The maximum amount of time required to service an HTTP request</td>
</tr>
<tr>
<td>request.minTime</td>
<td>The minimum amount of time required to service an HTTP request</td>
</tr>
<tr>
<td>request.avg</td>
<td>The average amount of time required to service an HTTP request</td>
</tr>
<tr>
<td>request.active</td>
<td>The number of threads currently in the request processing phase</td>
</tr>
<tr>
<td>request.time</td>
<td>The total amount of time required to service an HTTP request</td>
</tr>
<tr>
<td>request.completed</td>
<td>The number of times the request processing phase was completed</td>
</tr>
</tbody>
</table>
### Chapter 12 • Web Application Server Resource Graphs

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>connection.maxTime</td>
<td>The maximum amount of time spent servicing any HTTP connection</td>
</tr>
<tr>
<td>connection.minTime</td>
<td>The minimum amount of time spent servicing any HTTP connection</td>
</tr>
<tr>
<td>connection.avg</td>
<td>The average amount of time spent servicing HTTP connections</td>
</tr>
<tr>
<td>connection.active</td>
<td>The number of connections with currently open threads</td>
</tr>
<tr>
<td>connection.time</td>
<td>The total amount of time spent servicing HTTP connections</td>
</tr>
<tr>
<td>connection.completed</td>
<td>The number of times the connection processing phase was completed</td>
</tr>
<tr>
<td>numMods.value</td>
<td>The number of loaded modules</td>
</tr>
<tr>
<td>childFinish.count</td>
<td>The number of times the Apache parent server started a child server, for any reason</td>
</tr>
<tr>
<td>childStart.count</td>
<td>The number of times “children” finished “gracefully.”There are some ungraceful error/crash cases that are not counted in childFinish.count</td>
</tr>
<tr>
<td>Decline.count</td>
<td>The number of times each module declined HTTP requests</td>
</tr>
<tr>
<td>internalRedirect.count</td>
<td>The number of times that any module passed control to another module using an “internal redirect”</td>
</tr>
<tr>
<td>cpuTime.value</td>
<td>The total CPU time utilized by all processes on the Apache server (measured in CPU milliseconds)</td>
</tr>
<tr>
<td>heapSize.value</td>
<td>The total heap memory utilized by all processes on the Apache server (measured in kilobytes)</td>
</tr>
<tr>
<td>pid.value</td>
<td>The process identifier of the parent Apache process</td>
</tr>
<tr>
<td>upTime.value</td>
<td>The amount of time the server been running (measured in milliseconds)</td>
</tr>
</tbody>
</table>
## SilverStream Graph

The following default measurements are available for the SilverStream server:

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>#Idle Sessions</td>
<td>The number of sessions in the Idle state.</td>
</tr>
<tr>
<td>Avg. Request processing time</td>
<td>The average request processing time.</td>
</tr>
<tr>
<td>Bytes Sent/sec</td>
<td>The rate at which data bytes are sent from the Web server.</td>
</tr>
<tr>
<td>Current load on Web Server</td>
<td>The percentage of load utilized by the SilverStream server, scaled at a factor of 25.</td>
</tr>
<tr>
<td>Hits/sec</td>
<td>The HTTP request rate.</td>
</tr>
<tr>
<td>Total sessions</td>
<td>The total number of sessions.</td>
</tr>
<tr>
<td>Free memory</td>
<td>The total amount of memory in the Java Virtual Machine currently available for future allocated objects.</td>
</tr>
<tr>
<td>Total memory</td>
<td>The total amount of memory in the Java Virtual Machine.</td>
</tr>
<tr>
<td>Memory Garbage Collection Count</td>
<td>The total number of times the JAVA Garbage Collector has run since the server was started.</td>
</tr>
<tr>
<td>Free threads</td>
<td>The current number of threads not associated with a client connection and available for immediate use.</td>
</tr>
<tr>
<td>Idle threads</td>
<td>The number of threads associated with a client connection, but not currently handling a user request.</td>
</tr>
<tr>
<td>Total threads</td>
<td>The total number of client threads allocated.</td>
</tr>
</tbody>
</table>
Note: The SilverStream monitor connects to the Web server in order to
gather statistics, and registers one hit for each sampling. The SilverStream
graph, therefore, always displays one hit per second, even if no clients are
connected to the SilverStream server.

**WebLogic (SNMP) Graph**

The following default measurements are available for the WebLogic (SNMP)
server (for versions earlier than 6.0):

- **Server Table**

  The Server Table lists all WebLogic (SNMP) servers that are being monitored
  by the agent. A server must be contacted or be reported as a member of a
  cluster at least once before it will appear in this table. Servers are only
  reported as a member of a cluster when they are actively participating in the
  cluster, or shortly thereafter.

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>ServerState</strong></td>
<td>The state of the WebLogic server, as inferred by the SNMP agent. <em>Up</em> implies that the agent can contact the server. <em>Down</em> implies that the agent cannot contact the server.</td>
</tr>
<tr>
<td><strong>ServerLoginEnable</strong></td>
<td>This value is true if client logins are enabled on the server.</td>
</tr>
<tr>
<td><strong>ServerMaxHeapSpace</strong></td>
<td>The maximum heap size for this server, in KB</td>
</tr>
<tr>
<td><strong>ServerHeapUsedPct</strong></td>
<td>The percentage of heap space currently in use on the server</td>
</tr>
<tr>
<td><strong>ServerQueueLength</strong></td>
<td>The current length of the server execute queue</td>
</tr>
<tr>
<td><strong>ServerQueueThroughput</strong></td>
<td>The current throughput of execute queue, expressed as the number of requests processed per second</td>
</tr>
</tbody>
</table>
Listen Table

The Listen Table is the set of protocol, IP address, and port combinations on which servers are listening. There will be multiple entries for each server: one for each protocol, ipAddr, port) combination. If clustering is used, the clustering-related MIB objects will assume a higher priority.

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ServerNumEJBDeployment</td>
<td>The total number of EJB deployment units known to the server</td>
</tr>
<tr>
<td>ServerNumEJBBeansDeployed</td>
<td>The total number of EJB beans actively deployed on the server</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ListenPort</td>
<td>Port number.</td>
</tr>
<tr>
<td>ListenAdminOK</td>
<td>True if admin requests are allowed on this (protocol, ipAddr, port); otherwise false</td>
</tr>
<tr>
<td>ListenState</td>
<td>Listening if the (protocol, ipAddr, port) is enabled on the server; not Listening if it is not. The server may be listening but not accepting new clients if its server Login Enable state is false. In this case, existing clients will continue to function, but new ones will not.</td>
</tr>
</tbody>
</table>
ClassPath Table

The ClassPath Table is the table of classpath elements for Java, WebLogic (SNMP) server, and servlets. There are multiple entries in this table for each server. There may also be multiple entries for each path on a server. If clustering is used, the clustering-related MIB objects will assume a higher priority.

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CPType</td>
<td>The type of CP element: Java, WebLogic, servlet. A Java CPType means the cpElement is one of the elements in the normal Java classpath. A WebLogic CPType means the cpElement is one of the elements in weblogic.class.path. A servlet CPType means the cpElement is one of the elements in the dynamic servlet classpath.</td>
</tr>
<tr>
<td>CPIndex</td>
<td>The position of an element within its path. The index starts at 1.</td>
</tr>
</tbody>
</table>

WebLogic (JMX) Graph

The following default measurements are available for the WebLogic (JMX) server (for versions higher than 6.0):

LogBroadcasterRuntime

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>MessagesLogged</td>
<td>The number of total log messages generated by this instance of the WebLogic server.</td>
</tr>
<tr>
<td>Registered</td>
<td>Returns “false” if the MBean represented by this object has been unregistered.</td>
</tr>
<tr>
<td>CachingDisabled</td>
<td>Private property that disables caching in proxies.</td>
</tr>
</tbody>
</table>
ServerRuntime

For more information on the measurements contained in each of the following measurement categories, see Mercury Interactive’s Load Testing Monitors Web site:
http://www-svca.mercuryinteractive.com/resources/library/technical/loadtesting_monitors/supported.html

➤ ServletRuntime
➤ WebAppComponentRuntime
➤ EJBStatefulHomeRuntime
➤ JTARuntime
➤ JVMRuntime
➤ EJBEntityHomeRuntime.
➤ DomainRuntime
➤ EJBComponentRuntime
➤ DomainLogHandlerRuntime
➤ JDBCConnectionPoolRuntime
➤ ExecuteQueueRuntime
➤ ClusterRuntime
➤ JMSRuntime
➤ TimeServiceRuntime
➤ EJBStatelessHomeRuntime
➤ WLECCConnectionServiceRuntime
### ServerSecurityRuntime

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>UnlockedUsersTotalCount</td>
<td>Returns the number of times a user has been unlocked on the server</td>
</tr>
<tr>
<td>InvalidLoginUsersHighCount</td>
<td>Returns the high-water number of users with outstanding invalid login attempts for the server</td>
</tr>
<tr>
<td>LoginAttemptsWhileLockedTotalCount</td>
<td>Returns the cumulative number of invalid logins attempted on the server while the user was locked</td>
</tr>
<tr>
<td>Registered</td>
<td>Returns “false” if the MBean represented by this object has been unregistered.</td>
</tr>
<tr>
<td>LockedUsersCurrentCount</td>
<td>Returns the number of currently locked users on the server</td>
</tr>
<tr>
<td>CachingDisabled</td>
<td>Private property that disables caching in proxies.</td>
</tr>
<tr>
<td>InvalidLoginAttemptsTotalCount</td>
<td>Returns the cumulative number of invalid logins attempted on the server</td>
</tr>
<tr>
<td>UserLockoutTotalCount</td>
<td>Returns the cumulative number of user lockouts done on the server</td>
</tr>
</tbody>
</table>
WebSphere Graph

The following measurements are available for the WebSphere server:

➤ Run-Time Resources
Contains resources related to the Java Virtual Machine run-time, as well as the ORB.

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>MemoryFree</td>
<td>The amount of free memory remaining in the Java Virtual Machine</td>
</tr>
<tr>
<td>MemoryTotal</td>
<td>The total memory allocated for the Java Virtual Machine</td>
</tr>
<tr>
<td>MemoryUse</td>
<td>The total memory in use within the Java Virtual Machine</td>
</tr>
</tbody>
</table>

➤ BeanData
Every home on the server provides performance data, depending upon the type of bean deployed in the home. The top level bean data holds an aggregate of all the containers.

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BeanCreates</td>
<td>The number of beans created. Applies to an individual bean that is either ‘stateful’ or ‘entity’</td>
</tr>
<tr>
<td>EntityBeanCreates</td>
<td>The number of entity beans created</td>
</tr>
<tr>
<td>BeanRemoves</td>
<td>The number of entity beans pertaining to a specific bean that have been removed. Applies to an individual bean that is either ‘stateful’ or ‘entity’</td>
</tr>
<tr>
<td>EntityBeanRemoves</td>
<td>The number of entity beans removed</td>
</tr>
<tr>
<td>StatefulBeanCreates</td>
<td>The number of stateful beans created</td>
</tr>
<tr>
<td>StatefulBeanRemoves</td>
<td>The number of stateful bean removed</td>
</tr>
</tbody>
</table>
### Chapter 12 • Web Application Server Resource Graphs

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BeanPassivates</td>
<td>The number of bean passivates pertaining to a specific bean. Applies to an individual bean that is either 'stateful' or 'entity'</td>
</tr>
<tr>
<td>EntityBeanPassivates</td>
<td>The number of entity bean passivates</td>
</tr>
<tr>
<td>StatefulBeanPassivates</td>
<td>The number of stateful bean passivates</td>
</tr>
<tr>
<td>BeanActivates</td>
<td>The number of bean activates pertaining to a specific bean. Applies to an individual bean that is either 'stateful' or 'entity'</td>
</tr>
<tr>
<td>EntityBeanActivates</td>
<td>The number of entity bean activates</td>
</tr>
<tr>
<td>StatefulBeanActivates</td>
<td>The number of stateful bean activates</td>
</tr>
<tr>
<td>BeanLoads</td>
<td>The number of times the bean data was loaded. Applies to entity</td>
</tr>
<tr>
<td>BeanStores</td>
<td>The number of times the bean data was stored in the database. Applies to entity</td>
</tr>
<tr>
<td>BeanInstantiates</td>
<td>The number of times a bean object was created. This applies to an individual bean, regardless of its type.</td>
</tr>
<tr>
<td>StatelessBeanInstantiates</td>
<td>The number of times a stateless session bean object was created</td>
</tr>
<tr>
<td>StatefulBeanInstantiates</td>
<td>The number of times a stateful session bean object was created</td>
</tr>
<tr>
<td>EntityBeanInstantiates</td>
<td>The number of times an entity bean object was created</td>
</tr>
<tr>
<td>BeanDestroys</td>
<td>The number of times an individual bean object was destroyed. This applies to any bean, regardless of its type</td>
</tr>
<tr>
<td>StatelessBeanDestroys</td>
<td>The number of times a stateless session bean object was destroyed</td>
</tr>
<tr>
<td>StatefulBeanDestroys</td>
<td>The number of times a stateful session bean object was destroyed</td>
</tr>
<tr>
<td>Measurement</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>EntityBeanDestroys</td>
<td>The number of times an entity bean object was destroyed</td>
</tr>
<tr>
<td>BeansActive</td>
<td>The average number of instances of active beans pertaining to a specific bean. Applies to an individual bean that is either ‘stateful’ or ‘entity’</td>
</tr>
<tr>
<td>EntityBeansActive</td>
<td>The average number of active entity beans</td>
</tr>
<tr>
<td>StatefulBeansActive</td>
<td>The average number of active session beans</td>
</tr>
<tr>
<td>BeansLive</td>
<td>The average number of bean objects of this specific type that are instantiated but not yet destroyed. This applies to an individual bean, regardless of its type.</td>
</tr>
<tr>
<td>StatelessBeansLive</td>
<td>The average number of stateless session bean objects that are instantiated but not yet destroyed</td>
</tr>
<tr>
<td>StatefulBeansLive</td>
<td>The average number of stateful session bean objects that are instantiated but not yet destroyed</td>
</tr>
<tr>
<td>EntityBeansLive</td>
<td>The average number of entity bean objects that are instantiated but not yet destroyed</td>
</tr>
<tr>
<td>BeanMethodRT</td>
<td>The average method response time for all methods defined in the remote interface to this bean. Applies to all beans</td>
</tr>
<tr>
<td>BeanMethodActive</td>
<td>The average number of methods being processed concurrently. Applies to all beans</td>
</tr>
<tr>
<td>BeanMethodCalls</td>
<td>The total number of method calls against this bean</td>
</tr>
</tbody>
</table>
The server holds a cache of bean objects. Each home has a cache and there is therefore one BeanObjectPoolContainer per container. The top level BeanObjectPool holds an aggregate of all the containers data.

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BeanObjectPoolContainer</td>
<td>The pool of a specific bean type</td>
</tr>
<tr>
<td>BeanObject</td>
<td>The pool specific to a home</td>
</tr>
<tr>
<td>NumGet</td>
<td>The number of calls retrieving an object from the pool</td>
</tr>
<tr>
<td>NumGetFound</td>
<td>The number of calls to the pool that resulted in finding an available bean</td>
</tr>
<tr>
<td>NumPuts</td>
<td>The number of beans that were released to the pool</td>
</tr>
<tr>
<td>NumPutsDiscarded</td>
<td>The number of times releasing a bean to the pool resulted in the bean being discarded because the pool was full</td>
</tr>
<tr>
<td>NumDrains</td>
<td>The number of times the daemon found the pool was idle and attempted to clean it</td>
</tr>
<tr>
<td>DrainSize</td>
<td>The average number of beans discarded by the daemon during a clean</td>
</tr>
<tr>
<td>BeanPoolSize</td>
<td>The average number of beans in the pool</td>
</tr>
</tbody>
</table>

These are resources related to the ORB thread pool that is on the server.

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ActiveThreads</td>
<td>The average number of active threads in the pool</td>
</tr>
<tr>
<td>TotalThreads</td>
<td>The average number of threads in the pool</td>
</tr>
<tr>
<td>PercentTimeMaxed</td>
<td>The average percent of the time that the number of threads in the pool reached or exceeded the desired maximum number</td>
</tr>
</tbody>
</table>
These are resources related to the database connection manager. The manager consists of a series of data sources, as well as a top-level aggregate of each of the performance metrics.

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ThreadCreates</td>
<td>The number of threads created</td>
</tr>
<tr>
<td>ThreadDestroys</td>
<td>The number of threads destroyed</td>
</tr>
<tr>
<td>ConfiguredMaxSize</td>
<td>The configured maximum number of pooled threads</td>
</tr>
</tbody>
</table>

**DBConnectionMgr**

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DataSource</td>
<td>Resources related to a specific data source specified by the &quot;name&quot; attribute</td>
</tr>
<tr>
<td>ConnectionCreates</td>
<td>The number of connections created</td>
</tr>
<tr>
<td>ConnectionDestroys</td>
<td>The number of connections released</td>
</tr>
<tr>
<td>ConnectionPoolSize</td>
<td>The average size of the pool, i.e., number of connections</td>
</tr>
<tr>
<td>ConnectionAllocates</td>
<td>The number of times a connection was allocated</td>
</tr>
<tr>
<td>ConnectionWaiters</td>
<td>The average number of threads waiting for a connection</td>
</tr>
<tr>
<td>ConnectionWaitTime</td>
<td>The average time, in seconds, of a connection grant</td>
</tr>
<tr>
<td>ConnectionTime</td>
<td>The average time, in seconds, that a connection is in use</td>
</tr>
<tr>
<td>ConnectionPercentUsed</td>
<td>The average percentage of the pool that is in use</td>
</tr>
<tr>
<td>ConnectionPercentMaxed</td>
<td>The percentage of the time that all connections are in use</td>
</tr>
</tbody>
</table>
➤ TransactionData

These are resources that pertain to transactions.

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NumTransactions</td>
<td>The number of transactions processed</td>
</tr>
<tr>
<td>ActiveTransactions</td>
<td>The average number of active transactions</td>
</tr>
<tr>
<td>TransactionRT</td>
<td>The average duration of each transaction</td>
</tr>
<tr>
<td>BeanObjectCount</td>
<td>The average number of bean object pools involved in a transaction</td>
</tr>
<tr>
<td>RolledBack</td>
<td>The number of transactions rolled back</td>
</tr>
<tr>
<td>Committed</td>
<td>The number of transactions committed</td>
</tr>
<tr>
<td>LocalTransactions</td>
<td>The number of transactions that were local</td>
</tr>
<tr>
<td>TransactionMethodCount</td>
<td>The average number of methods invoked as part of each transaction</td>
</tr>
<tr>
<td>Timeouts</td>
<td>The number of transactions that timed out due to inactivity timeouts</td>
</tr>
<tr>
<td>TransactionSuspended</td>
<td>The average number of times that a transaction was suspended</td>
</tr>
</tbody>
</table>

➤ ServletEngine

These are resources that are related to servlets and JSPs.

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ServletsLoaded</td>
<td>The number of servlets currently loaded</td>
</tr>
<tr>
<td>ServletRequests</td>
<td>The number of requests serviced</td>
</tr>
<tr>
<td>CurrentRequests</td>
<td>The number of requests currently being serviced</td>
</tr>
<tr>
<td>ServletRT</td>
<td>The average response time for each request</td>
</tr>
<tr>
<td>ServletsActive</td>
<td>The average number of servlets actively processing requests</td>
</tr>
</tbody>
</table>
### Sessions

These are general metrics regarding the HTTP session pool.

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ServletIdle</td>
<td>The amount of time that the server has been idle (i.e., time since last request)</td>
</tr>
<tr>
<td>ServletErrors</td>
<td>The number of requests that resulted in an error or an exception</td>
</tr>
<tr>
<td>ServletBeanCalls</td>
<td>The number of bean method invocations that were made by the servlet</td>
</tr>
<tr>
<td>ServletBeanCreates</td>
<td>The number of bean references that were made by the servlet</td>
</tr>
<tr>
<td>ServletDBCalls</td>
<td>The number of database calls made by the servlet</td>
</tr>
<tr>
<td>ServletDBConAlloc</td>
<td>The number of database connections allocated by the servlet</td>
</tr>
<tr>
<td>SessionLoads</td>
<td>The number of times the servlet session data was read from the database</td>
</tr>
<tr>
<td>SessionStores</td>
<td>The number of times the servlet session data was stored in the database</td>
</tr>
<tr>
<td>SessionSize</td>
<td>The average size, in bytes, of a session data</td>
</tr>
<tr>
<td>LoadedSince</td>
<td>The time that has passed since the server was loaded (UNC time)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SessionsCreated</td>
<td>The number of sessions created on the server</td>
</tr>
<tr>
<td>SessionsActive</td>
<td>The number of currently active sessions</td>
</tr>
<tr>
<td>SessionsInvalidated</td>
<td>The number of invalidated sessions. May not be valid when using sessions in the database mode</td>
</tr>
<tr>
<td>SessionLifetime</td>
<td>Contains statistical data of sessions that have been invalidated. Does not include sessions that are still alive</td>
</tr>
</tbody>
</table>
After running a scenario, you can use Database Server Resource graphs to analyze the resource usage of your DB2, Oracle, and SQL Server databases.

This chapter describes:

➤ DB2 Graph
➤ Oracle Graph
➤ SQL Server Graph

About Database Server Resource Graphs

The Database Server Resource graphs show statistics for several database servers. Currently DB2, Oracle, and SQL Server databases are supported. These graphs require that you specify the resources you want to measure before running the scenario. For more information, see the section on online monitors in the Astra LoadTest Controller User's Guide.
**DB2 Graph**

The DB2 graph shows the resource usage on the DB2 database server machine as a function of the elapsed scenario time.

The following tables describe the default counters that can be monitored on a DB2 server:

**DatabaseManager**

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>rem_cons_in</td>
<td>The current number of connections initiated from remote clients to the instance of the database manager that is being monitored.</td>
</tr>
<tr>
<td>rem_cons_in_exec</td>
<td>The number of remote applications that are currently connected to a database and are currently processing a unit of work within the database manager instance being monitored.</td>
</tr>
<tr>
<td>local_cons</td>
<td>The number of local applications that are currently connected to a database within the database manager instance being monitored.</td>
</tr>
<tr>
<td>local_cons_in_exec</td>
<td>The number of local applications that are currently connected to a database within the database manager instance being monitored and are currently processing a unit of work.</td>
</tr>
<tr>
<td>con_local_dbases</td>
<td>The number of local databases that have applications connected.</td>
</tr>
<tr>
<td>agents_registered</td>
<td>The number of agents registered in the database manager instance that is being monitored (coordinator agents and subagents).</td>
</tr>
<tr>
<td>agents_waiting_on_token</td>
<td>The number of agents waiting for a token so they can execute a transaction in the database manager.</td>
</tr>
<tr>
<td>idle_agents</td>
<td>The number of agents in the agent pool that are currently unassigned to an application and are therefore “idle”.</td>
</tr>
</tbody>
</table>
### Chapter 13 • Database Server Resource Graphs

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>agents_from_pool</td>
<td>The number of agents assigned from the agent pool</td>
</tr>
<tr>
<td>agents_created_empty_pool</td>
<td>The number of agents created because the agent pool was empty.</td>
</tr>
<tr>
<td>agents_stolen</td>
<td>The number of times that agents are stolen from an application. Agents are stolen when an idle agent associated with an application is reassigned to work on a different application.</td>
</tr>
<tr>
<td>comm_private_mem</td>
<td>The amount of private memory that the instance of the database manager has currently committed at the time of the snapshot.</td>
</tr>
<tr>
<td>inactive_gw_agents</td>
<td>The number of DRDA agents in the DRDA connections pool that are primed with a connection to a DRDA database, but are inactive.</td>
</tr>
<tr>
<td>num_gw_conn_switches</td>
<td>The number of times that an agent from the agents pool was primed with a connection and was stolen for use with a different DRDA database.</td>
</tr>
<tr>
<td>sort_heap_allocated</td>
<td>The total number of allocated pages of sort heap space for all sorts at the level chosen and at the time the snapshot was taken.</td>
</tr>
<tr>
<td>post_threshold_sorts</td>
<td>The number of sorts that have requested heaps after the sort heap threshold has been reached.</td>
</tr>
<tr>
<td>piped_sorts_requested</td>
<td>The number of piped sorts that have been requested.</td>
</tr>
<tr>
<td>piped_sorts_accepted</td>
<td>The number of piped sorts that have been accepted.</td>
</tr>
</tbody>
</table>
### Database

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>appls_cur_cons</code></td>
<td>Indicates the number of applications that are currently connected to the database.</td>
</tr>
<tr>
<td><code>appls_in_db2</code></td>
<td>Indicates the number of applications that are currently connected to the database, and for which the database manager is currently processing a request.</td>
</tr>
<tr>
<td><code>total_sec_cons</code></td>
<td>The number of connections made by a sub-agent to the database at the node.</td>
</tr>
<tr>
<td><code>num_assoc_agents</code></td>
<td>At the application level, this is the number of sub-agents associated with an application. At the database level, it is the number of sub-agents for all applications.</td>
</tr>
<tr>
<td><code>sort_heap_allocated</code></td>
<td>The total number of allocated pages of sort heap space for all sorts at the level chosen and at the time the snapshot was taken.</td>
</tr>
<tr>
<td><code>total_sorts</code></td>
<td>The total number of sorts that have been executed.</td>
</tr>
<tr>
<td><code>total_sort_time</code></td>
<td>The total elapsed time (in milliseconds) for all sorts that have been executed.</td>
</tr>
<tr>
<td><code>sort_overflows</code></td>
<td>The total number of sorts that ran out of sort heap and may have required disk space for temporary storage.</td>
</tr>
<tr>
<td><code>active_sorts</code></td>
<td>The number of sorts in the database that currently have a sort heap allocated.</td>
</tr>
<tr>
<td><code>total_hash_joins</code></td>
<td>The total number of hash joins executed.</td>
</tr>
<tr>
<td><code>total_hash_loops</code></td>
<td>The total number of times that a single partition of a hash join was larger than the available sort heap space.</td>
</tr>
<tr>
<td><code>hash_join_overflows</code></td>
<td>The number of times that hash join data exceeded the available sort heap space.</td>
</tr>
<tr>
<td>Measurement</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>hash_join_small_overflows</td>
<td>The number of times that hash join data exceeded the available sort heap space by less than 10%.</td>
</tr>
<tr>
<td>pool_data_l_reads</td>
<td>Indicates the number of logical read requests for data pages that have gone through the buffer pool.</td>
</tr>
<tr>
<td>pool_data_p_reads</td>
<td>The number of read requests that required I/O to get data pages into the buffer pool.</td>
</tr>
<tr>
<td>pool_data_writes</td>
<td>Indicates the number of times a buffer pool data page was physically written to disk.</td>
</tr>
<tr>
<td>pool_index_l_reads</td>
<td>Indicates the number of logical read requests for index pages that have gone through the buffer pool.</td>
</tr>
<tr>
<td>pool_index_p_reads</td>
<td>Indicates the number of physical read requests to get index pages into the buffer pool.</td>
</tr>
<tr>
<td>pool_index_writes</td>
<td>Indicates the number of times a buffer pool index page was physically written to disk.</td>
</tr>
<tr>
<td>pool_read_time</td>
<td>Provides the total amount of elapsed time spent processing read requests that caused data or index pages to be physically read from disk to buffer pool.</td>
</tr>
<tr>
<td>pool_write_time</td>
<td>Provides the total amount of time spent physically writing data or index pages from the buffer pool to disk.</td>
</tr>
<tr>
<td>files_closed</td>
<td>The total number of database files closed.</td>
</tr>
<tr>
<td>pool_async_data_reads</td>
<td>The number of pages read asynchronously into the buffer pool.</td>
</tr>
<tr>
<td>pool_async_data_writes</td>
<td>The number of times a buffer pool data page was physically written to disk by either an asynchronous page cleaner, or a pre-fetcher. A pre-fetcher may have written dirty pages to disk to make space for the pages being pre-fetched.</td>
</tr>
</tbody>
</table>
### Measurement Description

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>pool_async_index_writes</td>
<td>The number of times a buffer pool index page was physically written to disk by either an asynchronous page cleaner, or a pre-fetcher. A pre-fetcher may have written dirty pages to disk to make space for the pages being pre-fetched.</td>
</tr>
<tr>
<td>pool_async_index_reads</td>
<td>The number of index pages read asynchronously into the buffer pool by a pre-fetcher.</td>
</tr>
<tr>
<td>pool_async_read_time</td>
<td>The total elapsed time spent reading by database manager pre-fetchers.</td>
</tr>
<tr>
<td>pool_async_write_time</td>
<td>The total elapsed time spent writing data or index pages from the buffer pool to disk by database manager page cleaners.</td>
</tr>
<tr>
<td>pool_async_data_read_reqs</td>
<td>The number of asynchronous read requests.</td>
</tr>
<tr>
<td>pool_lsn_gap_clns</td>
<td>The number of times a page cleaner was invoked because the logging space used had reached a pre-defined criterion for the database.</td>
</tr>
<tr>
<td>pool_drty_pg_steal_clns</td>
<td>The number of times a page cleaner was invoked because a synchronous write was needed during the victim buffer replacement for the database.</td>
</tr>
<tr>
<td>pool_drty_pg_thrsh_clns</td>
<td>The number of times a page cleaner was invoked because a buffer pool had reached the dirty page threshold criterion for the database.</td>
</tr>
<tr>
<td>prefetch_wait_time</td>
<td>The time an application spent waiting for an I/O server (pre-fetcher) to finish loading pages into the buffer pool.</td>
</tr>
<tr>
<td>pool_data_to_estore</td>
<td>The number of buffer pool data pages copied to extended storage.</td>
</tr>
<tr>
<td>pool_index_to_estore</td>
<td>The number of buffer pool index pages copied to extended storage.</td>
</tr>
<tr>
<td>pool_data_from_estore</td>
<td>The number of buffer pool data pages copied from extended storage.</td>
</tr>
<tr>
<td>pool_index_from_estore</td>
<td>The number of buffer pool index pages copied from extended storage.</td>
</tr>
<tr>
<td>Measurement</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>direct_reads</td>
<td>The number of read operations that do not use the buffer pool.</td>
</tr>
<tr>
<td>direct_writes</td>
<td>The number of write operations that do not use the buffer pool.</td>
</tr>
<tr>
<td>direct_read_reqs</td>
<td>The number of requests to perform a direct read of one or more sectors of data.</td>
</tr>
<tr>
<td>direct_write_reqs</td>
<td>The number of requests to perform a direct write of one or more sectors of data.</td>
</tr>
<tr>
<td>direct_read_time</td>
<td>The elapsed time (in milliseconds) required to perform the direct reads.</td>
</tr>
<tr>
<td>direct_write_time</td>
<td>The elapsed time (in milliseconds) required to perform the direct writes.</td>
</tr>
<tr>
<td>cat_cache_lookups</td>
<td>The number of times that the catalog cache was referenced to obtain table descriptor information.</td>
</tr>
<tr>
<td>cat_cache_inserts</td>
<td>The number of times that the system tried to insert table descriptor information into the catalog cache.</td>
</tr>
<tr>
<td>cat_cache_overflows</td>
<td>The number of times that an insert into the catalog cache failed due the catalog cache being full.</td>
</tr>
<tr>
<td>cat_cache_heap_full</td>
<td>The number of times that an insert into the catalog cache failed due to a heap-full condition in the database heap.</td>
</tr>
<tr>
<td>pkg_cache_lookups</td>
<td>The number of times that an application looked for a section or package in the package cache. At a database level, it indicates the overall number of references since the database was started, or monitor data was reset.</td>
</tr>
<tr>
<td>pkg_cache Inserts</td>
<td>The total number of times that a requested section was not available for use and had to be loaded into the package cache. This count includes any implicit prepares performed by the system.</td>
</tr>
<tr>
<td>Measurement</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>pkg_cache_num_overflows</td>
<td>The number of times that the package cache overflowed the bounds of its allocated memory.</td>
</tr>
<tr>
<td>appl_section_lookups</td>
<td>Lookups of SQL sections by an application from its SQL work area.</td>
</tr>
<tr>
<td>appl_section_inserts</td>
<td>Inserts of SQL sections by an application from its SQL work area.</td>
</tr>
<tr>
<td>sec_logs_allocated</td>
<td>The total number of secondary log files that are currently being used for the database.</td>
</tr>
<tr>
<td>log_reads</td>
<td>The number of log pages read from disk by the logger.</td>
</tr>
<tr>
<td>log_writes</td>
<td>The number of log pages written to disk by the logger.</td>
</tr>
<tr>
<td>total_log_used</td>
<td>The total amount of active log space currently used (in bytes) in the database.</td>
</tr>
<tr>
<td>locks_held</td>
<td>The number of locks currently held.</td>
</tr>
<tr>
<td>lock_list_in_use</td>
<td>The total amount of lock list memory (in bytes) that is in use.</td>
</tr>
<tr>
<td>deadlocks</td>
<td>The total number of deadlocks that have occurred.</td>
</tr>
<tr>
<td>lock_escals</td>
<td>The number of times that locks have been escalated from several row locks to a table lock.</td>
</tr>
<tr>
<td>x_lock_escals</td>
<td>The number of times that locks have been escalated from several row locks to one exclusive table lock, or the number of times an exclusive lock on a row caused the table lock to become an exclusive lock.</td>
</tr>
<tr>
<td>lock_timeouts</td>
<td>The number of times that a request to lock an object timed-out instead of being granted.</td>
</tr>
<tr>
<td>lock_waits</td>
<td>The total number of times that applications or connections waited for locks.</td>
</tr>
<tr>
<td>lock_wait_time</td>
<td>The total elapsed time waited for a lock.</td>
</tr>
<tr>
<td>Measurement</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------</td>
<td>------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>locks_waiting</td>
<td>Indicates the number of agents waiting on a lock.</td>
</tr>
<tr>
<td>rows_deleted</td>
<td>The number of row deletions attempted.</td>
</tr>
<tr>
<td>rows_inserted</td>
<td>The number of row insertions attempted.</td>
</tr>
<tr>
<td>rows_updated</td>
<td>The number of row updates attempted.</td>
</tr>
<tr>
<td>rows_selected</td>
<td>The number of rows that have been selected and returned to the application.</td>
</tr>
<tr>
<td>int_rows_deleted</td>
<td>The number of rows deleted from the database as a result of internal activity.</td>
</tr>
<tr>
<td>int_rows_updated</td>
<td>The number of rows updated from the database as a result of internal activity.</td>
</tr>
<tr>
<td>int_rows_inserted</td>
<td>The number of rows inserted into the database as a result of internal activity caused by triggers.</td>
</tr>
<tr>
<td>static_sql_stmts</td>
<td>The number of static SQL statements that were attempted.</td>
</tr>
<tr>
<td>dynamic_sql_stmts</td>
<td>The number of dynamic SQL statements that were attempted.</td>
</tr>
<tr>
<td>failed_sql_stmts</td>
<td>The number of SQL statements that were attempted, but failed.</td>
</tr>
<tr>
<td>commit_sql_stmts</td>
<td>The total number of SQL COMMIT statements that have been attempted.</td>
</tr>
<tr>
<td>rollback_sql_stmts</td>
<td>The total number of SQL ROLLBACK statements that have been attempted.</td>
</tr>
<tr>
<td>select_sql_stmts</td>
<td>The number of SQL SELECT statements that were executed.</td>
</tr>
<tr>
<td>uid_sql_stmts</td>
<td>The number of SQL UPDATE, INSERT, and DELETE statements that were executed.</td>
</tr>
<tr>
<td>ddl_sql_stmts</td>
<td>This element indicates the number of SQL Data Definition Language (DDL) statements that were executed.</td>
</tr>
</tbody>
</table>
### Application

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>agents_stolen</td>
<td>The number of times that agents are stolen from an application. Agents are stolen when an idle agent associated with an application is reassigned to work on a different application.</td>
</tr>
<tr>
<td>num_assoc_agents</td>
<td>At the application level, this is the number of sub-agents associated with an application. At the database level, it is the number of sub-agents for all applications.</td>
</tr>
<tr>
<td>total_sorts</td>
<td>The total number of sorts that have been executed.</td>
</tr>
<tr>
<td>total_sort_time</td>
<td>The total elapsed time (in milliseconds) for all sorts that have been executed.</td>
</tr>
<tr>
<td>sort_overflows</td>
<td>The total number of sorts that ran out of sort heap and may have required disk space for temporary storage.</td>
</tr>
<tr>
<td>total_hash_joins</td>
<td>The total number of hash joins executed.</td>
</tr>
<tr>
<td>Measurement</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>total_hash_loops</td>
<td>The total number of times that a single partition of a hash join was larger than the available sort heap space.</td>
</tr>
<tr>
<td>hash_join_overflows</td>
<td>The number of times that hash join data exceeded the available sort heap space</td>
</tr>
<tr>
<td>hash_join_small_overflows</td>
<td>The number of times that hash join data exceeded the available sort heap space by less than 10%.</td>
</tr>
<tr>
<td>pool_data_l_reads</td>
<td>Indicates the number of logical read requests for data pages that have gone through the buffer pool.</td>
</tr>
<tr>
<td>pool_data_p_reads</td>
<td>The number of read requests that required I/O to get data pages into the buffer pool.</td>
</tr>
<tr>
<td>pool_data_writes</td>
<td>Indicates the number of times a buffer pool data page was physically written to disk.</td>
</tr>
<tr>
<td>pool_index_l_reads</td>
<td>Indicates the number of logical read requests for index pages that have gone through the buffer pool.</td>
</tr>
<tr>
<td>pool_index_p_reads</td>
<td>Indicates the number of physical read requests to get index pages into the buffer pool.</td>
</tr>
<tr>
<td>pool_index_writes</td>
<td>Indicates the number of times a buffer pool index page was physically written to disk.</td>
</tr>
<tr>
<td>pool_read_time</td>
<td>Provides the total amount of elapsed time spent processing read requests that caused data or index pages to be physically read from disk to buffer pool.</td>
</tr>
<tr>
<td>prefetch_wait_time</td>
<td>The time an application spent waiting for an I/O server (pre-fetcher) to finish loading pages into the buffer pool.</td>
</tr>
<tr>
<td>pool_data_to_estore</td>
<td>The number of buffer pool data pages copied to extended storage.</td>
</tr>
<tr>
<td>pool_index_to_estore</td>
<td>The number of buffer pool index pages copied to extended storage.</td>
</tr>
</tbody>
</table>
## Measurement Description

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>pool_data_from_estore</td>
<td>The number of buffer pool data pages copied from extended storage.</td>
</tr>
<tr>
<td>pool_index_from_estore</td>
<td>The number of buffer pool index pages copied from extended storage.</td>
</tr>
<tr>
<td>direct_reads</td>
<td>The number of read operations that do not use the buffer pool.</td>
</tr>
<tr>
<td>direct_writes</td>
<td>The number of write operations that do not use the buffer pool.</td>
</tr>
<tr>
<td>direct_read_reqs</td>
<td>The number of requests to perform a direct read of one or more sectors of data.</td>
</tr>
<tr>
<td>direct_write_reqs</td>
<td>The number of requests to perform a direct write of one or more sectors of data.</td>
</tr>
<tr>
<td>direct_read_time</td>
<td>The elapsed time (in milliseconds) required to perform the direct reads.</td>
</tr>
<tr>
<td>direct_write_time</td>
<td>The elapsed time (in milliseconds) required to perform the direct writes.</td>
</tr>
<tr>
<td>cat_cache_lookups</td>
<td>The number of times that the catalog cache was referenced to obtain table descriptor information.</td>
</tr>
<tr>
<td>cat_cache Inserts</td>
<td>The number of times that the system tried to insert table descriptor information into the catalog cache.</td>
</tr>
<tr>
<td>cat_cache_overflows</td>
<td>The number of times that an insert into the catalog cache failed due the catalog cache being full.</td>
</tr>
<tr>
<td>cat_cache_heap_full</td>
<td>The number of times that an insert into the catalog cache failed due to a heap-full condition in the database heap.</td>
</tr>
<tr>
<td>pkg_cache_lookups</td>
<td>The number of times that an application looked for a section or package in the package cache. At a database level, it indicates the overall number of references since the database was started, or monitor data was reset.</td>
</tr>
<tr>
<td>Measurement</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>pkg_cache_inserts</td>
<td>The total number of times that a requested section was not available for use and had to be loaded into the package cache. This count includes any implicit prepares performed by the system.</td>
</tr>
<tr>
<td>appl_section_lookups</td>
<td>Lookups of SQL sections by an application from its SQL work area.</td>
</tr>
<tr>
<td>appl_section_inserts</td>
<td>Inserts of SQL sections by an application from its SQL work area.</td>
</tr>
<tr>
<td>uow_log_space_used</td>
<td>The amount of log space (in bytes) used in the current unit of work of the monitored application.</td>
</tr>
<tr>
<td>locks_held</td>
<td>The number of locks currently held.</td>
</tr>
<tr>
<td>deadlocks</td>
<td>The total number of deadlocks that have occurred.</td>
</tr>
<tr>
<td>lock_escals</td>
<td>The number of times that locks have been escalated from several row locks to a table lock.</td>
</tr>
<tr>
<td>x_lock_escals</td>
<td>The number of times that locks have been escalated from several row locks to one exclusive table lock, or the number of times an exclusive lock on a row caused the table lock to become an exclusive lock.</td>
</tr>
<tr>
<td>lock_timeouts</td>
<td>The number of times that a request to lock an object timed-out instead of being granted.</td>
</tr>
<tr>
<td>lock_waits</td>
<td>The total number of times that applications or connections waited for locks.</td>
</tr>
<tr>
<td>lock_wait_time</td>
<td>The total elapsed time waited for a lock.</td>
</tr>
<tr>
<td>locks_waiting</td>
<td>Indicates the number of agents waiting on a lock.</td>
</tr>
<tr>
<td>uow_lock_wait_time</td>
<td>The total amount of elapsed time this unit of work has spent waiting for locks.</td>
</tr>
<tr>
<td>rows_deleted</td>
<td>The number of row deletions attempted.</td>
</tr>
<tr>
<td>Measurement</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>rows_inserted</td>
<td>The number of row insertions attempted.</td>
</tr>
<tr>
<td>rows_updated</td>
<td>The number of row updates attempted.</td>
</tr>
<tr>
<td>rows_selected</td>
<td>The number of rows that have been selected and returned to the application.</td>
</tr>
<tr>
<td>rows_written</td>
<td>The number of rows changed (inserted, deleted or updated) in the table.</td>
</tr>
<tr>
<td>rows_read</td>
<td>The number of rows read from the table.</td>
</tr>
<tr>
<td>int_rows_deleted</td>
<td>The number of rows deleted from the database as a result of internal activity.</td>
</tr>
<tr>
<td>int_rows_updated</td>
<td>The number of rows updated from the database as a result of internal activity.</td>
</tr>
<tr>
<td>int_rows_inserted</td>
<td>The number of rows inserted into the database as a result of internal activity caused by triggers.</td>
</tr>
<tr>
<td>open_rem_curs</td>
<td>The number of remote cursors currently open for this application, including those cursors counted by 'open_rem_curs_blk'.</td>
</tr>
<tr>
<td>open_rem_curs_blk</td>
<td>The number of remote blocking cursors currently open for this application.</td>
</tr>
<tr>
<td>rej_curs_blk</td>
<td>The number of times that a request for an I/O block at server was rejected and the request was converted to non-blocked I/O.</td>
</tr>
<tr>
<td>acc_curs_blk</td>
<td>The number of times that a request for an I/O block was accepted.</td>
</tr>
<tr>
<td>open_loc_curs</td>
<td>The number of local cursors currently open for this application, including those cursors counted by 'open_loc_curs_blk'.</td>
</tr>
<tr>
<td>open_loc_curs_blk</td>
<td>The number of local blocking cursors currently open for this application.</td>
</tr>
<tr>
<td>static_sql_stmts</td>
<td>The number of static SQL statements that were attempted.</td>
</tr>
<tr>
<td>Measurement</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>dynamic_sql_stmts</td>
<td>The number of dynamic SQL statements that were attempted.</td>
</tr>
<tr>
<td>failed_sql_stmts</td>
<td>The number of SQL statements that were attempted, but failed.</td>
</tr>
<tr>
<td>commit_sql_stmts</td>
<td>The total number of SQL COMMIT statements that have been attempted.</td>
</tr>
<tr>
<td>rollback_sql_stmts</td>
<td>The total number of SQL ROLLBACK statements that have been attempted.</td>
</tr>
<tr>
<td>select_sql_stmts</td>
<td>The number of SQL SELECT statements that were executed.</td>
</tr>
<tr>
<td>uid_sql_stmts</td>
<td>The number of SQL UPDATE, INSERT, and DELETE statements that were executed.</td>
</tr>
<tr>
<td>ddl_sql_stmts</td>
<td>This element indicates the number of SQL Data Definition Language (DDL) statements that were executed.</td>
</tr>
<tr>
<td>int_auto_rebinds</td>
<td>The number of automatic rebinds (or recompiles) that have been attempted.</td>
</tr>
<tr>
<td>int_commits</td>
<td>The total number of commits initiated internally by the database manager.</td>
</tr>
<tr>
<td>int_rollbacks</td>
<td>The total number of rollbacks initiated internally by the database manager.</td>
</tr>
<tr>
<td>int_deadlock_rollbacks</td>
<td>The total number of forced rollbacks initiated by the database manager due to a deadlock. A rollback is performed on the current unit of work in an application selected by the database manager to resolve the deadlock.</td>
</tr>
<tr>
<td>binds_precompiles</td>
<td>The number of binds and pre-compiles attempted.</td>
</tr>
</tbody>
</table>
Oracle Graph

The Oracle graph displays information from Oracle V$ tables: Session statistics, V$SESSTAT, and system statistics, V$SYSSTAT.

In the following Oracle graph, the V$SYSSTAT resource values are shown as a function of the elapsed scenario time.

![Oracle Graph]

The following measurements are most commonly used when monitoring the Oracle server (from the V$SYSSTAT table):

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CPU used by this session</td>
<td>This is the amount of CPU time (in 10s of milliseconds) used by a session between the time a user call started and ended. Some user calls can be completed within 10 milliseconds and, as a result, the start and end user-call time can be the same. In this case, 0 milliseconds are added to the statistic. A similar problem can exist in the operating system reporting, especially on systems that suffer from many context switches.</td>
</tr>
<tr>
<td>Bytes received via SQL*Net from client</td>
<td>The total number of bytes received from the client over Net8</td>
</tr>
</tbody>
</table>
### Measurement Description

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Logons current</td>
<td>The total number of current logons</td>
</tr>
<tr>
<td>Opens of replaced files</td>
<td>The total number of files that needed to be reopened because they were no longer in the process file cache</td>
</tr>
<tr>
<td>User calls</td>
<td>Oracle allocates resources (Call State Objects) to keep track of relevant user call data structures every time you log in, parse, or execute. When determining activity, the ratio of user calls to RPI calls gives you an indication of how much internal work gets generated as a result of the type of requests the user is sending to Oracle.</td>
</tr>
<tr>
<td>SQL*Net roundtrips to/from client</td>
<td>The total number of Net8 messages sent to, and received from, the client</td>
</tr>
<tr>
<td>Bytes sent via SQL*Net to client</td>
<td>The total number of bytes sent to the client from the foreground process(es)</td>
</tr>
<tr>
<td>Opened cursors current</td>
<td>The total number of current open cursors</td>
</tr>
<tr>
<td>DB block changes</td>
<td>Closely related to consistent changes, this statistic counts the total number of changes that were made to all blocks in the SGA that were part of an update or delete operation. These are changes that are generating redo log entries and hence will be permanent changes to the database if the transaction is committed. This statistic is a rough indication of total database work and indicates (possibly on a per-transaction level) the rate at which buffers are being dirtied.</td>
</tr>
<tr>
<td>Total file opens</td>
<td>The total number of file opens being performed by the instance. Each process needs a number of files (control file, log file, database file) in order to work against the database.</td>
</tr>
</tbody>
</table>
The SQL Server graph shows the standard Windows resources on the SQL server machine.

The following table describes the default counters that can be monitored on version 6.5 of the SQL Server:

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>% Total Processor Time (NT)</td>
<td>The average percentage of time that all the processors on the system are busy executing non-idle threads. On a multi-processor system, if all processors are always busy, this is 100%, if all processors are 50% busy this is 50% and if 1/4th of the processors are 100% busy this is 25%. It can be viewed as the fraction of the time spent doing useful work. Each processor is assigned an Idle thread in the Idle process which consumes those unproductive processor cycles not used by any other threads.</td>
</tr>
<tr>
<td>Cache Hit Ratio</td>
<td>The percentage of time that a requested data page was found in the data cache (instead of being read from disk)</td>
</tr>
<tr>
<td>Measurement</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>I/O - Batch Writes/sec</td>
<td>The number of 2K pages written to disk per second, using Batch I/O. The checkpoint thread is the primary user of Batch I/O.</td>
</tr>
<tr>
<td>I/O - Lazy Writes/sec</td>
<td>The number of 2K pages flushed to disk per second by the Lazy Writer.</td>
</tr>
<tr>
<td>I/O - Outstanding Reads</td>
<td>The number of physical reads pending</td>
</tr>
<tr>
<td>I/O - Outstanding Writes</td>
<td>The number of physical writes pending</td>
</tr>
<tr>
<td>I/O - Page Reads/sec</td>
<td>The number of physical page reads per second</td>
</tr>
<tr>
<td>I/O - Transactions/sec</td>
<td>The number of Transact-SQL command batches executed per second</td>
</tr>
<tr>
<td>User Connections</td>
<td>The number of open user connections</td>
</tr>
<tr>
<td>% Processor Time (Win 2000)</td>
<td>The percentage of time that the processor is executing a non-idle thread. This counter was designed as a primary indicator of processor activity. It is calculated by measuring the time that the processor spends executing the thread of the idle process in each sample interval, and subtracting that value from 100%. (Each processor has an idle thread which consumes cycles when no other threads are ready to run). It can be viewed as the percentage of the sample interval spent doing useful work. This counter displays the average percentage of busy time observed during the sample interval. It is calculated by monitoring the time the service was inactive, and then subtracting that value from 100%.</td>
</tr>
</tbody>
</table>
The Analysis utility lets you compare results and graphs to determine the source of a problem.

This chapter discusses:

➤ Cross Result Graphs
➤ Generating Cross Result Graphs
➤ Merging Graphs
➤ Creating a Merged Graph

**About Cross Result and Merged Graphs**

Comparing results is essential for determining bottlenecks and problems. You use Cross Result graphs to compare the results of multiple scenario runs. You create Merged graphs to compare results from different graphs within the same scenario run.
Cross Result Graphs

Cross Result graphs are useful for:

➤ benchmarking hardware
➤ testing software versions
➤ determining system capacity

If you want to benchmark two hardware configurations, you run the same scenario with both configurations and compare the transaction response times using a single Cross Result graph.

Suppose that your vendor claims that a new software version is optimized to run quicker than a previous version. You can verify this claim by running the same scenario on both versions of the software, and comparing the scenario results.

You can also use Cross Result graphs to determine your system’s capacity. You run scenarios using different numbers of Vusers running the same script. By analyzing Cross Result graphs, you can determine the number of users that cause unacceptable response times.

In the following example, two scenario runs are compared by crossing their results, res12, and res15. The same script was executed twice—first with 100 Vusers and then with 50 Vusers. In the first run, the average transaction time was approximately 59 seconds. In the second run, the average time was...
4.7 seconds. It is apparent that the system works much slower with a greater load.

The Cross Result graphs have an additional filter and group by category: *Result Name*. The above graph is filtered to the *OrderRide* transaction for results *res12*, and *res15*, grouped by *Result Name*. 
Generating Cross Result Graphs

You can create a Cross Result graph for two or more result sets.

To generate a Cross Result graph:


2. Click Add to add an additional result set to the Result List. The Select Result Files for Cross Results dialog box opens.

3. Locate a results directory and select its result file (.lrr). Click OK. The scenario is added to the Result List.

4. Repeat steps 2 and 3 until all the results you want to compare are in the Result List.

5. When you generate a Cross Result graph, by default it is saved as a new Analysis session. To save it in an existing session, clear the Create New Analysis Session for Cross Result check box.

6. Click OK. The Analysis processes the result data and asks for a confirmation to open the default graphs.

After you generate a Cross Result graph, you can filter it to display specific scenarios and transactions. You can also manipulate the graph by changing the granularity, zoom, and scale. For more information, see Chapter 2, “Working with Analysis Graphs.”
Chapter 14 • Cross Result and Merged Graphs

Merging Graphs

The Analysis lets you merge the results of two graphs from the same scenario into a single graph. The merging allows you to compare several different measurements at once. For example, you can make a merged graph to display the network delay and number of running Vusers, as a function of the elapsed time.

In order to merge graphs, their x-axis must be the same measurement. For example, you can merge Web Throughput and Hits per second, because the common x-axis is Scenario Elapsed Time. The drop-down list only shows the active graphs with an x-axis common with the current graph. The Analysis provides three types of merging:

➤ Overlay
➤ Tile
➤ Correlate

Overlay: Superimpose the contents of two graphs that share a common x-axis. The left y-axis on the merged graph shows the current graph’s values. The right y-axis shows the values of the graph that was merged. There is no limit to the number of graphs that you can overlay. When you overlay two graphs, the y-axis for each graph is displayed separately to the right and left of the graph. When you overlay more than two graphs, the Analysis displays a single y-axis, scaling the different measurements accordingly.
In the following example, the Throughput and Hits per Second graph are overlaid with one another.

**Tile:** View contents of two graphs that share a common x-axis in a tiled layout, one above the other. In the following example the Throughput and Hits per Second graph are tiled one above the other.

**Correlate:** Plot the y-axis of two graphs against each other. The active graph's y-axis becomes the x-axis of the merged graph. The y-axis of the graph that was merged, becomes the merged graph's y-axis.
In the following example, the Throughput and Hits per Second graph are correlated with one another. The x-axis displays the Bytes per Second (the Throughput measurement) and the y-axis shows the Hits per Second.

**Creating a Merged Graph**

You can merge all graphs with a common x-axis.

**To create a merged graph:**

1. Select a graph in the tree view or click on its tab to make it active.
Choose View > Merge Graphs or click the Merge Graphs button. The Merge Graphs dialog box opens and displays the name of the active graph.

Select a graph with which you want to merge your active graph. Only the graphs with a common x-axis to the active graph are available.

Select the type of merge: Overlay, Tile, or Correlate.

Specify a title for the merged graph. By default, the Analysis combines the titles of the two graphs being merged.

Click OK.

Filter the graph just as you would filter any ordinary graph.
After running a scenario, you can use the Analysis reports to analyze the performance of your application.

This chapter describes:

➤ Viewing Summary Reports
➤ Creating HTML Reports

**About Analysis Reports**

After running a scenario, you can view reports that summarize your system’s performance. The Analysis provides the following reporting tools:

➤ Summary report
➤ HTML reports

The Summary report provides general information about the scenario run. You can view the Summary report at any time from the Analysis window.

You can instruct the Analysis to create an HTML report. The Analysis creates an HTML report for each one of the open graphs.
Viewing Summary Reports

The Summary report provides general information about scenario execution. This report is always available from the tree view or as a tab in the Analysis window. It lists statistics about the scenario run and provides links to the following graphs: Running Vusers, Throughput, Hits Per Second, HTTP Responses per Second, Transaction Summary, and Average Transaction Response Time. At the bottom of the page, the Summary report displays a table containing the scenario’s transaction data. Included in this data is a 90 Percent column, indicating the maximum response time for ninety percent of the transactions.

You can save the Summary report to an Excel file by selecting View > Export Summary to Excel.
Creating HTML Reports

The Analysis lets you create HTML reports for your scenario run. It creates a separate report for each one of the open graphs and a Summary report. The Summary report is identical to the Summary report that you access from the Analysis window. The report also provides a link to an Excel file containing the graph data.

To create HTML reports:

1. Open all graphs that you want to be included in the report.
2. Choose Reports > HTML Report or click the Create HTML Report button. The Select Report Filename and Path dialog box opens.
3 Specify a path and file name for the HTML report and click **OK**. The Analysis saves a Summary report called by the file name in the selected folder, and the rest of the graphs in a folder with the same name as the file name. When you create an HTML report, the Analysis opens your default browser and displays the Summary report.

4 To view an HTML report for one of the graphs, click on its link in the left frame.

5 To copy the HTML reports to another location, be sure to copy the filename and the folder with the same name. For example, if you named your HTML report *test1*, copy *test1.html* and the folder *test1* to the desired location.
Managing Results Using TestDirector

Astra LoadTest integration with TestDirector lets you manage using TestDirector, Mercury Interactive’s test management tool.

This chapter describes:

➤ Connecting to and Disconnecting from TestDirector
➤ Creating a New Session Using TestDirector
➤ Opening an Existing Session Using TestDirector
➤ Saving Sessions to a TestDirector Project

About Managing Results Using TestDirector

Astra LoadTest works together with TestDirector to provide an efficient method for storing and retrieving scenarios and collecting results. You store scenarios and results in a TestDirector project and organize them into unique groups.

In order for Astra LoadTest to access a TestDirector project, you must connect it to the Web server on which TestDirector is installed. You can connect to either a local or remote Web server.

For more information on working with TestDirector, refer to the TestDirector User’s Guide.
Connecting to and Disconnecting from TestDirector

If you are working with both Astra LoadTest and TestDirector, Astra LoadTest can communicate with your TestDirector project. You can connect or disconnect Astra LoadTest from a TestDirector project at any time during an Analysis session.

Connecting Astra LoadTest to TestDirector

The connection process has two stages. First, you connect Astra LoadTest to a local or remote TestDirector Web server. This server handles the connections between Astra LoadTest and the TestDirector project.

Next, you choose the project you want Astra LoadTest to access. The project stores scenarios and results for the application you are testing. Note that TestDirector projects are password protected, so you must provide a user name and a password.

To connect Astra LoadTest to TestDirector:

1. In the Analysis, choose Tools > TestDirector Connection. The TestDirector Connection dialog box opens.
In the Server box, type the URL address of the Web server on which TestDirector is installed.

**Note:** You can choose a Web server accessible via a Local Area Network (LAN) or a Wide Area Network (WAN).

3 Click **Connect**. Once the connection to the server is established, the server’s name is displayed in read-only format in the Server box.

4 From the Project box in the Project Connection section, select a TestDirector project.

5 In the User Name box, type a user name.

6 In the Password box, type a password.

7 Click **Connect** to connect Astra LoadTest to the selected project.

   Once the connection to the selected project is established, the project’s name is displayed in read-only format in the Project box.

8 To automatically reconnect to the TestDirector server and the selected project on startup, select the **Reconnect on startup** check box.

9 If you select **Reconnect on startup**, you can save the specified password to reconnect on startup. Select the **Save password for reconnection on startup** check box.

   If you do not save your password, you will be prompted to enter it when Astra LoadTest connects to TestDirector on startup.

10 Click **Close** to close the TestDirector Connection dialog box.
**Disconnecting Astra LoadTest from TestDirector**

You can disconnect Astra LoadTest from a selected TestDirector project and Web server.

**To disconnect Astra LoadTest from TestDirector:**

1. In the Controller, choose **Tools > TestDirector Connection**. The TestDirector Connection dialog box opens.

2. To disconnect Astra LoadTest from the selected project, click **Disconnect** in the Project Connection section.

3. To disconnect Astra LoadTest from the selected server, click **Disconnect** in the Server Connection section.

4. Click **Close** to close the TestDirector Connection dialog box.
Creating a New Session Using TestDirector

When Astra LoadTest is connected to a TestDirector project, you can create a new Analysis session using a result file (.lrr extension) stored in TestDirector. You locate result files according to their position in the test plan tree, rather than by their actual location in the file system.

To create a new session using results from a TestDirector project:

1. Connect to the TestDirector server (see “Connecting Astra LoadTest to TestDirector” on page 192).

2. In the Analysis, choose File > New or click the Create New Analysis Session button. The Open Result File for New Analysis Session from TestDirector Project dialog box opens and displays the test plan tree.
To open a result file directly from the file system, click the File System button. The Open Result File for New Analysis Session dialog box opens. (From the Open Result File for New Analysis Session dialog box, you may return to the Open Result File for New Analysis Session from TestDirector Project dialog box by clicking the TestDirector button.)

3 Click the relevant subject in the test plan tree. To expand the tree and view sublevels, double-click closed folders. To collapse the tree, double-click open folders.

Note that when you select a subject, the sessions that belong to the subject appear in the Run Name list.

4 Select an Analysis session from the Run Name list. The scenario appears in the read-only Test Name box.

5 Click OK to open the session. Astra LoadTest loads the session. The name of the session appears in the Analysis title bar.

---

Note: You can also open Analysis sessions from the recent session list in the File menu. If you select a session located in a TestDirector project, but Astra LoadTest is currently not connected to that project, the TestDirector Connection dialog box opens. Enter your user name and password to log in to the project, and click OK.
Opening an Existing Session Using TestDirector

When Astra LoadTest is connected to a TestDirector project, you can open an existing Analysis session from TestDirector. You locate sessions according to their position in the test plan tree, rather than by their actual location in the file system.

To open a session from a TestDirector project:

1. Connect to the TestDirector server (see “Connecting Astra LoadTest to TestDirector” on page 192).
2. In the Controller, choose File > Open or click the File Open button. The Open Existing Analysis Session File from TestDirector Project dialog box opens and displays the test plan tree.

To open a scenario directly from the file system, click the File System button. The Open Existing Analysis Session File dialog box opens. (From the Open Existing Analysis Session File dialog box, you may return to the Open Existing Analysis Session File from TestDirector Project dialog box by clicking the TestDirector button.)
3 Click the relevant subject in the test plan tree. To expand the tree and view sublevels, double-click closed folders. To collapse the tree, double-click open folders.

Note that when you select a subject, the sessions that belong to the subject appear in the Run Name list.

4 Select a session from the Run Name list. The session appears in the read-only Test Name box.

5 Click OK to open the session. Astra LoadTest loads the session. The name of the session appears in the Analysis title bar.

---

Note: You can also open sessions from the recent sessions list in the File menu. If you select a session located in a TestDirector project, but Astra LoadTest is currently not connected to that project, the TestDirector Connection dialog box opens. Enter your user name and password to log in to the project, and click OK.

---

**Saving Sessions to a TestDirector Project**

When Astra LoadTest is connected to a TestDirector project, you can create new sessions in Astra LoadTest and save them directly to your project. To save a session, you give it a descriptive name and associate it with the relevant subject in the test plan tree. This helps you to keep track of the sessions created for each subject and to quickly view the progress of test planning and creation.

**To save a session to a TestDirector project:**

1 Connect to the TestDirector server (see “Connecting Astra LoadTest to TestDirector” on page 192).

2 Select File > Save and save the session in the TestDirector data directory.
Interpreting Analysis Graphs

Astra LoadTest Analysis graphs present important information about the performance of your scenario. Using these graphs, you can identify and pinpoint bottlenecks in your Web system and determine what changes are needed to improve its performance.

This chapter presents examples of:

➤ Analyzing Transaction Performance
➤ Using the Web Page Breakdown Graphs
➤ Identifying Server Problems
➤ Identifying Network Problems
➤ Comparing Scenario Results

Analyzing Transaction Performance

The Average Transaction Response Time and Transaction Performance Summary graphs should be your starting point in analyzing a scenario run. Using the Transaction Performance Summary graph, you can determine which transaction(s) had a particularly high response time during scenario execution. Using the Average Transaction Response Time graph, you can view the behavior of the problematic transaction(s) during each second of the scenario run.
Question 1: Which transactions had the highest response time? Was the response time for these transactions high throughout the scenario, or only at certain points during scenario execution?

Answer: The Transaction Performance Summary graph demonstrates a summary of the minimum, average, and maximum response time for each transaction during scenario execution. In the example below, the response time of the Reservation transaction averaged 44.4 seconds during the course of the scenario.
Chapter 17 • Interpreting Analysis Graphs

The Average Transaction Response Time graph demonstrates that response time was high for the Reservation transaction throughout the scenario. Response time for this transaction was especially high—approximately 55 seconds—during the sixth and thirteenth minutes of the scenario.

![Average Transaction Response Time Graph]

In order to pinpoint the problem and understand why response time was high for the Reservation transaction during this scenario, it is necessary to break down the transactions and analyze the performance of each page component. To break down a transaction, right-click it in the Average Transaction Response Time or Transaction Performance Summary graph, and select **Web Page Breakdown for <transaction name>**.
Using the Web Page Breakdown Graphs

Using the Web Page Breakdown graphs, you can drill down on the Average Transaction Response Time or Transaction Performance Summary graphs in order to view the download time for each page component in a transaction. Note that this is possible only if you enabled the Web Page Breakdown feature before running your scenario.

Question 2: Which page components were responsible for the high transaction response time? Were the problems that occurred network- or server-related?

Answer: The Web Page Breakdown graph displays a breakdown of the download time for each page component in the Reservation transaction.
If the download time for a component was unacceptably long, note which measurements—DNS resolution time, connection time, time to first buffer, SSL handshaking time, receive time, and FTP authentication time—were responsible for the lengthy download. To view the point during the scenario at which the problem occurred, select the Page Download Breakdown (Over Time) graph. For more information regarding the measurements displayed, see “Page Download Time Breakdown Graph” on page 79.

To identify whether a problem is network- or server-related, select the Time to First Buffer Breakdown (Over Time).

The above graph demonstrates that the server time was much higher than the network time. If the server time is unusually high, use the appropriate server graph to identify the problematic server measurements and isolate the cause of server degradation. If the network time is unusually high, use the Network Monitor graphs to determine what network problems caused the performance bottleneck.
Identifying Server Problems

Web site performance problems can be a result of many factors. Nearly half of the performance problems, however, can be traced to Web, Web application, and database server malfunctioning. Dynamic Web sites that rely heavily on database operations are particularly at risk for performance problems.

The most common database problems are inefficient index design, fragmented databases, out-of-date statistics, and faulty application design. Database system performance can therefore be improved by using smaller result sets, automatically updating data, optimizing indexes, frequently compacting data, implementing a query or a lock on time-outs, using shorter transactions, and avoiding application deadlocks.

In twenty percent of load tests, Web and Web application servers are found to be the cause of performance bottlenecks. The bottlenecks are usually the result of poor server configuration and insufficient resources. For example, poorly written code and DLLs can use nearly all of a computer’s processor time (CPU) and create a bottleneck on the server. Likewise, physical memory constraints and mismanagement of server memory can easily cause a server bottleneck. It is therefore advisable to check both the CPU and physical memory of your server before exploring other possible causes of poor Web or Web application server performance.

For information about other useful Web, Web application, and database server measurements, see the Astra LoadTest Controller User’s Guide.

HTTPS Problems

Excessive use of HTTPS and other security measures can quickly exhaust server resources and contribute to system bottlenecks. For example, when HTTPS is implemented on the Web server during a load test, system resources are quickly exhausted by a relatively small load. This is caused by secured socket layer (SSL) resource-intensive operations.
Continuously open connections can also drain server resources. Unlike browsers, servers providing SSL services typically create numerous sessions with large numbers of clients. Caching the session identifiers from each transaction can quickly exhaust the server’s resources. In addition, the “keep-alive” enhancement features of most Web browsers keep connections open until they are explicitly terminated by the client or server. As a result, server resources may be wasted as large numbers of idle browsers remain connected to the server.

The performance of secured Web sites can be improved by:

➤ Fine-tuning the SSL and HTTPS services according to the type of application
➤ Using SSL hardware accelerators, such as SSL accelerator appliances and cards
➤ Changing the level of security according to the level of sensitivity of the data (i.e., changing the key length used for public-key encryption from 1,024 to 512 bits)
➤ Avoiding the excessive use of SSL and redesigning those pages that have low levels of data sensitivity to use regular HTTPS

**Identifying Network Problems**

Network bottlenecks can usually be identified when the load increment is considerable and is not significantly affecting any of the server side components, as in the case of informational sites using many static Web pages. In twenty-five percent of such cases, the pipe to the Internet cannot sufficiently handle the desired load and causes delays in incoming and outgoing requests. In addition, bottlenecks are frequently uncovered between the Web site and the ISP.

Using the Network Monitor graphs, you can determine whether, in fact, the network is causing a bottleneck. If the problem is network-related, you can locate the problematic segment so that it can be fixed.
Comparing Scenario Results

Each time the system is fine tuned and another performance bottleneck is resolved, the same load test should be run again in order to verify that the problem has been fixed and that no new performance bottlenecks have been created. After performing the load test several times, you can compare the initial results to the final results.

The following graph displays a comparison of an initial load test and a final load test for a scenario.

![Graph showing comparison of initial and final load tests]

The first load test demonstrates the application's performance in its initial state, before any load testing was performed. From the graph, you can see that with approximately 50 Vusers, response time was almost 90 seconds, indicating that the application suffered from severe performance problems.

Using the analysis process, it was possible to determine what architectural changes were necessary to improve the transaction response time. As a result of these site architectural changes, the transaction response time for the same business process, with the same number of users, was less than 10 seconds in the last load test performed. Using the Analysis, therefore, the customer was able to increase site performance tenfold.
# Index

## A
Acrobat Reader vii
advanced display settings
chart 34
series 35
aggregating data 5
Analysis
interiting graphs 199–206
overview 1–17
sessions 3
working with 19–41
Apache graph 114
Ariba graph 123
ASP graph 141
ATG Dynamo graph 125
Average Transaction Response Time
graph 48, 199

## B
Books Online vii
breaking down transactions 74
BroadVision graph 128
Brokat Twister graph 135

## C
chart settings 34
Check Point FireWall-1 graph 112
Client Time 81
ColdFusion graph 139
collating scenario results 4
comparing scenario runs 206
connecting to TestDirector 192
Connection time 80
Context Sensitive Help viii
conventions. See typographical conventions
coordinates of a point 20
Cross Result graphs 179–186

data aggregation 5
Data Points (Average) graph 93
Data Points (Sum) graph 92
Database options 10
DB2 graph 160
disconnecting from TestDirector 194
display options
advanced 34
standard 32
DNS Resolution time 80
documentation set viii
Downloaded Component Size graph 89
drill down 21
enlarging graphs 24
Error Time 81
Excel file
exporting to 38
viewing 189
filtering graphs 27
FireWall Server graphs 111–112
First Buffer time 80
FTP Authentication time 81
Fujitsu INTERSTAGE graph 140
G

General options 9
graph

Apache 114
Ariba 123
ATG Dynamo 125
Average Transaction Response
  Time 48
BroadVision 128
Brokat Twister 135
Check Point FireWall-1 112
ColdFusion 139
Data Points (Average) 93
Data Points (Sum) 92
DB2 160
Downloaded Component Size 89
Fujitsu INTERSTAGE 140
Hits per Second 60
HTTP Responses per Second 63
HTTP Status Code Summary 62
iPlanet/Netscape 118
Microsoft Active Server Pages
  (ASP) 141
Microsoft IIS 116
Network Delay Time 107
Network Segment Delay 109
Network Sub-Path Time 108
Oracle 174
Oracle9iAS HTTP 142
Page Component Breakdown 75
Page Component Breakdown
  (Over Time) 77
Page Download Time Breakdown 79
Page Download Time Breakdown
  (Over Time) 83
Pages Downloaded per Second 66
Rendezvous 46
Retries per Second 68
Retries Summary 69
Running Vusers 44
SilverStream 146
SNMP Resources 102
SQL Server 176
Throughput 61
Time to First Buffer Breakdown 85
graph (cont’d)
  Time to First Buffer Breakdown
    (Over Time) 87
  Total Transactions per second 51
  Transaction Performance
    Summary 53
  Transaction Response Time
    (Distribution) 56
  Transaction Response Time
    (Percentile) 55
  Transaction Response Time
    (Under Load) 54
  Transaction Summary 52
  Transactions per second 50
  TUXEDO Resources 103
  Vuser Summary 45
  WebLogic (JMX) 149
  WebLogic (SNMP) 147
  WebSphere 152
  Windows Resources 96
graph types, Analysis
  Database Server Resources 159–177
  FireWall Server Monitor 111–112
  Network Monitor 105–110
  System Resources 95–104
  Transaction 47–57
  User-Defined Data Points 91–93
  Vuser 43–46
  Web Application Server
    Resources 121–158
  Web Page Breakdown 71–90
  Web Resources 59–69
  Web Server Resources 113–119
graphs, working with
  background 35
crossing results 179–186
display options 32
  merging 183
overlaying, superimposing 183
Index

H
Hits per Second graph 60
HTML reports 189
HTTP Responses per Second graph 63
HTTP Status Code Summary graph 62
HTTPS 204

I
IIS graph 116
interpreting Analysis graphs 199–206
iPlanet/Netscape graph 118

L
legend 36
legend preferences 35

M
marks in a graph 35
measurement trends, viewing 40
Merging graphs 183
Microsoft Active Server Pages (ASP) graph 141
Microsoft IIS graph 116

N
Network Delay Time graph 107
Network Monitor graphs 105–110
Network Segment Delay graph 109
Network Sub-Path Time graph 108

O
Oracle graph 174
Oracle9iAS HTTP graph 142
Output window 2
overlay graphs 183

P
packets 106
Page Component Breakdown (Over Time) graph 77
Page Component Breakdown graph 75
Page Download Time Breakdown (Over Time) graph 83
Page Download Time Breakdown graph 79
Pages Downloaded per Second graph 66

R
raw data 38
Receive time 81
Rendezvous graph 46
reports 187–190
  HTML 189
  summary 188
Retries per Second graph 68
Retries Summary graph 69
Running Vusers graph 44

S
scale factor 113
scale of graph 24
security problems 204
Services.UserDataPoint(Value,Name) 91
session information 14
sessions 3
SilverStream graph 146
SNMP Resources graph 102
spreadsheet view 38
SQL Server graph 176
SSL Handshaking time 80
standardizing y-axis values 40
summary data, viewing 4
Summary report 188
superimposing graphs 183
Support Information viii
Support Online viii

T
templates
  applying 13
  saving 12
TestDirector
  integration 191–198
  opening a new session 195
  opening an existing session 197
  saving sessions to a project 198
TestDirector integration
  connecting to TestDirector 192
  disconnecting from TestDirector 194
three-dimensional properties 35
Throughput graph 61
time filter, setting 7
Time to First Buffer Breakdown (Over Time) graph 87
Time to First Buffer Breakdown graph 85
tool options
  setting database options 10
  setting general options 9
Total Transactions per Second graph 51
Transaction graphs 47–57
Transaction Performance Summary graph 53, 199
Transaction Response Time graphs 48–57
  Average 48
  Distribution 56
  Percentile 55
  Under Load 54
Transaction Summary graph 52
test, breakdown 74
Transactions per Second graph 50
TUXEDO graph 103
typographical conventions in this guide x

U
  user_data_point function 91
  User-Defined Data Point graphs 91–93

V
  viewing measurement trends 40
  Vuser graphs 43–46
  Vuser Summary graph 45

W
  Web Application Server Resource graphs 121–158
  Web Page Breakdown graphs 71–90, 202
  activating 73
  Web Resource graphs 59–69
  Web Server Resource graphs 113–119
  WebLogic (JMX) graph 149
  WebLogic (SNMP) graph 147
  WebSphere graph 152
  Windows Resources graph 96

X
  x-axis interval 24

Y
  y-axis values, standardizing 40

Z
  zoom 24