Service Virtualization monitors are not displayed in the online run screen in Performance Center

  • KM02234113
  • 12-Apr-2016
  • 03-May-2016

Summary

Service Virtualization monitors are not displayed in the online run screen in Performance Center. The following error is displayed: “Cannot access HKEY_PERFORMANCE_DATA on host with error Access is denied”

Error

Service Virtualization monitors are not shown in the online run screen in Performance Center. Furthermore, the following error is displayed in the output/messages window:

Monitor name: HP Simulation - Services. Cannot connect to <host-name>.
Reason: Cannot access HKEY_PERFORMANCE_DATA key on host myd-vm02858 with error
Access is denied.
(entry point: chkConnection).    [MsgId: MMSG-47281]
Hints:
Check that your login user name appears as administrator on this machine.
Check that remote registry is available on this machine.
Check that you have entered the correct machine name.
Check that the machine exists and that it is online (use the ping utility for this operation).
Delete the machine and add it again. (entry point: CFactory::Initialize).  [MsgId: MMSG-47299]

 

Cause

The issue happens because the Windows resource monitor lacks permissions to access the remote server registries for the Service Virtualization counters.

Fix

There are two ways to fix the issue, both involving a single registry key edit that does not require a server reboot. The difference between both ways is the number of users that will eventually gain access to the new registry keys required for accessing performance counters on a server. Both ways require a registry change as Microsoft has not implemented a way to change this setting via a UI.

Please refer to the following document for further details on the resolution:

LoadRunner Performance Monitoring Security Implementation